Netgate Pfsense Wireless (re0) Config Issues



  • Hello all, I'm hoping someone can help me on this but i'm having issues trying to get my Netgear R6300 (Running DD-WRT v24-sp2) working on re0 port of my Netgate.

    I've configured the interface 'Wireless' and mapped it to re0. My WAN is on re1, and LAN is on re2 ports. (Interfaces > Wireless)

    Also, I enabled DHCP for the Wireless interface. (Services > DHCP Server > Wireless) tab

    For testing, I also enabled an any/any rule for the internal Wireless adapter. (Firewall > Rules > Wireless) tab

    Whenever I plug my Netgear Wireless router into my Comcast Business router, it issues a rout-able IP allowing me to reach the internet. But if I plugin my Netgear Wireless to re0 on the Netgate PFSENSE box I don't get an IP.

    I'm at a loss of what I am doing wrong here and I've spent hours trying to figure it out. My end-goal is I want my Netgear Wireless router to get an IP issued from the PFSENSE box so I can still see my internal LAN.

    Thank you again for anyone who can assist me.



  • Why are you using DHCP? Couldn't you just assign a static IP in the correct range to your Netgear? Also, are you trying to use the WAN port? If you're just using it as an access point, you should be using one of the LAN ports. That is how I use my Netgear WNR3500L (running Tomato Shibby) as an access point with pfSense. Has worked fine for months.

    Carlos



  • Thanks for the reply Carlos. So, yes I also have tried a static without issuing a an IP through DHCP but still ran into the same issue. My current config for ports are:

    re0 Internal wireless
    re1 WAN
    re2 LAN

    you're saying it's specific of which port i should be using for wireless? i didn't think it mattered.



  • Your WAN port on the Netgear will be unused in a config like that, it's merely bridging. Configure its LAN with a static IP on that subnet so you can manage it.


  • LAYER 8 Netgate

    You need to just disable the WAN port and put it in access point mode. I think DDWRT calls that "Router" mode or some such nonsense (I think they call it that because it's intended to be used with another router or something.)



  • @twz2004:

    Thanks for the reply Carlos. So, yes I also have tried a static without issuing a an IP through DHCP but still ran into the same issue. My current config for ports are:

    re0 Internal wireless
    re1 WAN
    re2 LAN

    you're saying it's specific of which port i should be using for wireless? i didn't think it mattered.

    Sorry I should have been clearer. I was talking about the ports on your Netgear. As others have said, in your configuration, the WAN port on your Netgear should not be used.

    Out of curiosity, is there a reason you're using a dedicated port on Pfsense for wireless? It would probably be simpler to connect your Netgear to whatever switch you have connected to the LAN interface of the Pfsense box. That way you only need to manage one DHCP range.

    Carlos


  • LAYER 8 Netgate

    I think in most cases with DDWRT when you put it in the right mode the WAN port is just bridged with LAN and becomes another switch port.



  • Is the Netgear/DD-WRT router running as a router or as a WLAN AP?
    If there, at the Netgear, NAT will be done on the WAN Port it could be based on this issue that there will be no
    traffic running over this ports then.

    I would let the Netgear running in WLAN AP mode and let do the pfSense the entire DHCP part if needed.


Log in to reply