My pfSense box is bricked (Won't boot)



  • My wife's text said "The internet is down". I came home and found that I could not access the web console. I cold booted and now it does not complete start up. I'm at a screen that shows my link states as started on all 3 interfaces and won't go beyond that. I see a warning near the top of the page that says "Configuration references interfaces that do not exist". Not sure if this warning is related or not. My next step will be to boot using a Live CD/USB to see how far I get. In the meantime I thought I'd post for suggestions at determining root cause. I took a peak at some log files but don't see anything that stands out. Not sure if I'm looking in the right place.



  • That means you had an interface assigned that no longer exists after the system rebooted for some reason. If it just did that out of nowhere it's almost certainly because one or more NICs had a hardware failure, assuming you didn't have a more complicated config where virtual interfaces (gif, GRE, tun or tap) were assigned.



  • Not sure if I'm looking in the right place.

    Perhaps you got a electric power kick off for a small time and then the pfSense was writing garbage
    on the storage and now it wont boot any more related on the failing system. Could this also be?



  • My pfSense is an old Lenovo M58P. I ran the Lenovo Linux diagnostics disk and all checked out clean. I notice there was no option to check the NICs though. Are there any system logs that may give me an indication of what might have happened? I would hate to rebuild this thing only to have it brick again.



  • I had the exact issue a few weeks ago on my FW-7541. The WAN NIC must have had a surge come through as it wouldn't even show a link light. I received the same error you did but I was also prompted to assign interfaces. Since I had available NICs this was easy for me to fix. During bootup it will tell you which interface is missing. If you have an available NIC just reassign it otherwise you will either need to add or replace your NIC card then reassign the interface and you should be good.



  • If it is a flaky NIC it will be a bit harder for me to troubleshoot. All 3 NICs are showing as up on boot and the link light's are all green. I dread getting this running again only to have it crash soon after.



  • Heisenberg1977,

    When pfSense starts it will probe your hardware and let pfSense know what network hardware is available. Since you have 3 NICs on a M58P I'm assuming you have one onboard INTEL NIC and a PCI network card(s). When pfSense was working you might have had all 3 NICs assigned similar to this:
    WAN –> em0
    LAN --> em1
    OPT --> em2

    Now when pfSense boots it tries to assign these NICs to your interfaces. If one or more of these NICs are missing, pfSense cannot start because it was unable to find the NIC(s) to assign. If this happens you will receive a message that the interface doesn't exist. Here is a copy of what I got when this happened to me:

    Warning: Configuration references interfaces that do not exist: em5

    Network interface mismatch – Running interface assignment option.

    Valid interfaces are:

    em0    00:90:XX:XX:XX:XX  (up) Intel(R) PRO/1000 Network Connection 7.4.2
    em1    00:90:XX:XX:XX:XX  (up) Intel(R) PRO/1000 Network Connection 7.4.2
    em2    00:90:XX:XX:XX:XX  (up) Intel(R) PRO/1000 Network Connection 7.4.2
    em3    00:90:XX:XX:XX:XX  (up) Intel(R) PRO/1000 Network Connection 7.4.2
    em4    00:90:XX:XX:XX:XX  (up) Intel(R) PRO/1000 Network Connection 7.4.2

    Do you want to set up VLANs first?

    As you can see I had my WAN set to em5 but since it is bad it no longer exist. Boot up your box and as you see above it should list which interface are missing and which interfaces are valid(exist). From there this should tell you which NIC(s) needs to be changed. If you only had two interfaces assigned and have three NICs and one is bad you should be able to just reassign the interface. All you Firewall rules will still be there after you reassign.



  • All NICs are available leading me to believe that the problem is intermittent. I haven't had a chance to rebuild my pfSense yet, but am gearing up to do so soon. In order to isolate the problem, I will be redoing the NIC configuration. In my previous config I had the WAN running on the on board Intel NIC. I will change this to the LAN port. The other NIC is a dual port Intel pro/1000.

    Question?
    Would it be recommended to run both the WAN port and VLAN on the dual port NIC? Or should the WAN be on it's own dedicated card?

    I have one PCI x1 slot left if necessary to add an additional card. The issue is finding a compatible half-height legacy PCI Intel NIC that would fit in the M58P.