DHCP not cooperating (maybe?)



  • Hello pfSense forum.

    I am relatively new to pfSense.  Only had mine running since the middle of December.  I have worked through my share of quirks and missteps and made great use of the wonderful work and help of existing forum posts and various guides.  That being said I am currently having a very inconvenient issue to which I have not been able to find the answer.

    Some background to my problem is this (I am a bit long winded sorry, bear with me):  I have an older computer that had been running fine in my bedroom for a few years.  I upgraded the house to the current networking setup which includes a pfSense box, a switch, and a wifi AP, and it continued to run fine.  I was running windows 7.  When I decided to switch to linux, my computer would not connect to the internet anymore.  I managed to make that problem go away and I think what solved it was some good old fashioned turn-it-off-and-back-on-again with the router and some unplug-it-and-plug-it-back-in with the ethernet cable at the switch.  Did this have something to do with dhcp leases and not liking the new system?  I do not understand.

    OK so after typing this next part I realized how confusingly it was worded and how difficult it was to follow the room and computer combos so I decided maybe numbering them and rewriting would be of good.

    Room1 - My bedroom
    Room2 - neighboring bedroom
    Computer1 - My old pc recently replaced by Computer2 (trying to become a temporary fileserver before a full nas build)
    Computer2 - New build (z170 modest low power build)
    Computer3 - Really old family computer from the closet (dell/windowsvista shitbox)

    So Computer1 will not connect in room2 (says no ethernet is plugged in but it is).  Tried computer3 in room2 no connection (also says no ethernet connection).  Tried computer1 in room1 which worked with no changes just worked.  Tried moving computer2 which was working fine in room 1 into room 2 and that worked for some reason also.  Retried computer1 in room2 and was again unsuccessful.

    I dont understand why the same computer will connect on the same network in one room but not the other, and why that same room will willingly accept one computer and not another.  Is this a DHCP thing which, given my understanding of DHCP, is going wrong because I have done something wrong or just not done something I was supposed to?

    This post is perhaps a tad (or alot) poorly constructed, but any help is greatly appreciated.

    Thanks!



  • Are you using different wifi access points in each room of your house? It's not clear whether you get this issue when using directly connected ethernet cables from room to room, or whether this is a wifi-only issue. Are you using VLANs on your network? Are you using the same cables for each of the machines you're testing, or different ones?

    I can give a few guesses, but without further information they would be only guesses (One would be that your switch is faulty - another than your cables are faulty - but that's a big assumption given the information provided). It would help if you could post a diagram of your network setup, complete with any switch/VLAN information, wifi access points and indicate whether a connection is a wired one or a wireless one.


  • LAYER 8 Global Moderator

    Yeah bit confused here as well, are you talking wifi or wired here.. You say it says "says no ethernet connection"  That would mean wire, so you moving devices between rooms and plugging into a different port?

    If this is wifi, so your connecting to the wifi, but not getting an IP?  Does it give you a 169.254.x.x address?  This is what dhcp client will use if asks for dhcp address and gets no answer.  But that is not what the error no ethernet connected means..



  • Sorry for the confusion , this is all wired Ethernet.  Same wire in one room will work on some computer but not another.  I'm very lost.  There is a single ubiquity ap but none of thess machines have WiFi capability.  And when it says "no Ethernet connection" or however each is chooses to word it, there is definitely an Ethernet cable plugged in.  One that I can verify functions on a different machine.  When I go to a command line and ask it to tell me the IP address it tells me the link is down.  The Ethernet adapter is listed and it functions in a different room, but for whatever reason not in this one.  Also side note, when I say rooms its effectively just a different port on the switch.  Something I haven't tried yet is swapping the cables at the switch.  But if that miraculously fixed the problem j would still just be lucky and not understand.  Thanks again.


  • LAYER 8 Global Moderator

    well you can not get IP via dhcp if the line is DOWN…

    What switch are you using?  Seems like this could be a layer1 issue or layer 2...  But connection down.. nothing is going to work..  Your saying you plug in a different machine and it works?

    Is that port on the switch hard coded to a specific speed and duplex..

    So you have a switch that has cables that run to a jack on your wall in each room..  And all the rooms jacks go to the same switch?  And you say that room1 computer 1 works, and computer 2 works in room 2, but if you take computer 1 to room 2 it doesn't work and says interface down?

    Do you get any lights on the interface?

    What is the make and model of this switch, is it smart/managed.. You could have something like port security setup where you can not just move machines around from port to port because the switch locks on to the mac address of the first device connected, etc..

    Clarification of your wiring from room to room, and the switch make and model will help us help you find the root of your problem.  But again if the OS says the interface is down, then no its never in a million years going to work via dhcp or anything else.



  • johnpoz, the switch is most likely the problem.  When I have confirmed that it is the switch I'll report back.



  • Port speed and duplex mismatch is pretty much what I was thinking. In particular, if your network card on your PC is set to auto-detect and the port is as well, this can lead to potential latency issues, or even connection problems. Check the NIC settings on the PCs that work and compare that to the PC that doesn't. Same on the ports - assuming you're using a manged switch. See whether the working ports have static speed and/or duplex. The only other possibility I can see might be a faulty cable.


Log in to reply