Dnsmasq exited on signal 11



  • Hey guys, I've been having an issue with my PfSense machine for the last month or so two. It seems like once a day (sometimes two or three times a day), at a random time of day, my DNS Forwarder service (dnsmasq) stops working. It shows an "X" icon (not running) on the main PfSense GUI. Restarting it from the GUI works fine for a time.

    I've tried hard resetting, and upgrading to the latest release version of PfSense as well (2.2.6-RELEASE (i386)). But it seems to keep failing.

    This is what I'm getting in my system log when it stops working:

    kernel: pid 43335 (dnsmasq), uid 65534: exited on signal 11

    Followed by a bunch of:

    dhcpleases: Could not deliver signal HUP to process because its pidfile (/var/run/dnsmasq.pid) does not exist, No such process.p

    Which makes sense since the dnsmasq service is dead at that point.

    Nothing odd in the Resolver logs…

    If there's anything else I can provide to help diagnose this issue, please let me know! I'm not really sure what signal 11 is referring to, so if someone could point me in that direction, that would help too!



  • I am also having the same problem . After I updated to 2.2.6



  • I did it here and so far is working . Later back here to confirm.

    @cmb:

    @Pimmetje:

    Edit2:
    Also found a related ticket: https://redmine.pfsense.org/issues/5341

    which was happening on 2.2.4, so not likely the same issue as this thread which only started on 2.2.5.

    Found one change re: a crash here. That maybe sound like something that would happen in your environment?

    I compiled dnsmasq from the latest git.
    http://files.atx.pfsense.org/cmb/dnsmasq-2.76test1-25-g14a4ae8

    To replace yours with that, first make a copy of the existing so you can revert back if needed.

    cp /usr/local/sbin/dnsmasq /root/dnsmasq
    

    Then fetch that file into place.

    fetch -o /usr/local/sbin/dnsmasq http://files.atx.pfsense.org/cmb/dnsmasq-2.76test1-25-g14a4ae8
    

    make sure it's executable.

    chmod +x /usr/local/sbin/dnsmasq
    

    Then go to Status>Services and restart dnsmasq.

    If you need to revert back, run:

    cp /root/dnsmasq /usr/local/sbin/
    

    and restart under Status>Services.



  • It worked



  • version dnsmasq-2.76test1-25-g14a4ae8 not start on my pfsense 2.2.6



  • @Simon74:

    version dnsmasq-2.76test1-25-g14a4ae8 not start on my pfsense 2.2.6

    Same here.



  • Bump.

    Any other ideas since the above didn't work for a couple of us?



  • I only posted a 64 bit binary, those for whom it won't start are running 32 bit. There is a FreeBSD pkg available for dnsmasq-devel of a new enough version to fix this issue. Should be able to run:

    pkg install dnsmasq-devel
    

    to fix.



  • Perfect! Got 2.76test5 installed using this. Thanks! Will report back if it keeps up and stable!



  • One week and no crashes at all! Seems like this was the solution!


Log in to reply