Atheros 9287 Problems



  • Hi Guys

    I've just did a fresh install of pfSense 2.2.6 on a little fanless computer with with an Atheros 9287 PCIe card. I've configured it as per man ath for FreeBSD 10, however I keep getting the dmesg message:

    ath0: <atheros 9287=""> mem 0xf7c00000-0xf7c0ffff irq 18 at device 0.0 on pci3
    ioapic0: routing intpin 18 (PCI IRQ 18) to lapic 0 vector 68
    [ath]: Kiwi < 1.2 is not supported
    ath0: unable to attach hardware; HAL status 3
    device_attach: ath0 attach returned 6</atheros>
    

    My /boot/loader.conf.local file looks like this:

    legal.intel_wpi.license_ack=1
    legal.intel_ipw.license_ack=1
    legal.intel_iwi.license_ack=1
    
    if_ath_load="YES"
    if_ath_pci_load="YES"
    hw.ath.debug="1"
    hw.ath.hal.debug="1"
    boot_verbose="YES"
    kern.msgbufsize="655360"
    

    (I've read on other threads that the loader.conf.local will not be overwritten when updating as opposed to the loader.conf. However I have tried the settings in both files without success.)

    I've attached the the full dmesg log.

    I bought the wireless card from ebay, http://www.ebay.com.au/itm/NEW-Atheros-AR9287-AR5B97-Wireless-BGN-300M-Half-WIFI-Mini-PCI-E-Card-/310811974902?hash=item485dd65cf6:g:TTEAAOSwEK9T~Y2L

    The PC Is: http://www.hystou.com/products/mini-pc-thin-client/mini-desktop-computer/barebone-fanless-mini-computer-desktop-pc-intel-celeron-1037u-htpc-alloy-case-with-usb30-1084.html

    What is kiwi? Google was not much help.

    Looking at the HAL status code it means that "Hardware didn't respond as expected". Is this indicating that the card is faulty? (Just bought it a few days ago, so haven't tried it on anything else yet.)

    Any help would be greatly appreciated.

    Regards
    -Wynand
    dmesg.txt



  • Looking at the source code for the 9287 driver, I've noticed this:

    /* Don't support Kiwi < 1.2; those are pre-release chips */
    if (! AR_SREV_KIWI_12_OR_LATER(ah)) {
    	ath_hal_printf(ah, "[ath]: Kiwi < 1.2 is not supported\n");
    	ecode = HAL_EIO;
    	goto bad;
    }
    

    Looks like I probably go a device manufactured from non-production components (possibly even sample devices). :(

    Also Kiwi seems to just refer to the family name of the device, i.e. much like celeron, pentium, etc.

    Hope this helps someone else.

    -Wynand


Log in to reply