IOS Client timeout - Tunnelblick working


  • Hi folks,

    strange Problem:

    My OpenVPN-Config is working perfectly from my Mac Tunnelblick Client.

    But from iOS via OpenVPN Connect Client last thing logged is "connecting".
    The Server log shows: openvpn[17500]: xxxx:xxxx:xxxx:xxxx::xx TLS: Initial packet from [AF_INET6]xxxx:xxxx:xxxx:xxxx::xx:50840, sid=97xxx3b 6xxx2e4e. After that: nothing more - even at higher loglevel.

    Only "special" about that config: I'm using a portmapper to map IPv4 (internet) to IPv6 (my pfsense box).

    Any ideas?

    tia
    Tim

  • LAYER 8 Global Moderator

    "I'm using a portmapper to map IPv4 (internet) to IPv6 (my pfsense box)."

    huh??  What exactly is that setup?

    So On my iphone 5s, using the openvpn client - with my home pfsense, that I have he tunnel setup with /48 ipv6 and /64 segment used for vpn connections.. I can connect via ipv4, since we don't have any ipv6 here in the building wired or wireless.  Once I vpn in I get a ipv6 address on my ios device, and can ping ipv6 addresses through that tunnel.  Not the fastest.. I did this really quick, prob setting down and get better pings.. But this was seconds after I connected..



  • @johnpoz:

    "I'm using a portmapper to map IPv4 (internet) to IPv6 (my pfsense box)."

    huh??  What exactly is that setup?

    My home ISP only provides public IPv6, IPv4 is only behind NAT, so I have to use a portmapper to use my mobile iOS device which only has IPv4.

    Strange thing is, the setup works from my Mac but not from my iPhone (either via Wifi nor 3G/LTE).


  • Anyone?

    :(