Re: apinger daemon doesn't start at boot. (SOLVED)



  • Hi all,

    I'm having an issue with my pfSense box in that when I reboot the router, the apinger daemon doesn't start and I have to log on via the webpage interface and manually start the service.

    Does anyone know how to make this service start automatically?



  • … or could anyone tell me if there is a .sh script I can write and leave somewhere in the system to start the service automatically after boot?



  • it should get started at boot. if it doesn't there is an underlying issue that needs to be adressed instead of trying to work around it.

    try to post some logs from the time of boot.



  • Thanks for the reply heper.

    Looking at the gateway log, I get:

    Jan 9 13:01:08        apinger: No usable targets found, exiting
    Jan 9 13:01:08        apinger: Starting Alarm Pinger, apinger(17100)

    Do I need to change something in the gateway monitoring page?



  • whats in the system log?

    it appears apinger is started before the ethernet interface is working correctly



  • So, in order to actually view the system logs, I had to wipe them and disable snort, as this took up all of my 2000 lines that I could view.

    … and then when I did a reboot, apinger started first time?

    I've started snort again and have performed a reboot and voilà, apinger doesn't start at boot.

    Do you want to see the system logs with snort running to see the issue?



  • … or has anyone else found a resolution to this issue?



  • Not sure what helped, but changed a single line in the server config file…

    After local was my IP address, but changed this to my dyndns host name.

    Also added my modem on a virtual interface as a static IP and now everything works, even after reboots! :-D


Log in to reply