Upnp Crash



  • When i go to www.GRC.com and then shieldsup there is a button there called
    Instant upnp exposure test.
    https://www.grc.com/x/ne.dll?bh0bkyd2

    when i click it it will just kill my internet connection i have to reboot the pfsense box before internet works again.



  • Certainly not replicable. Why do you have to reboot? I presume the system's probably still reachable internally. What type of WAN? Gateway still reachable?



  • Considering these probes should be blocked by the firewall like any other unsolicited traffic, it would be odd for this to happen.



  • @cmb:

    Certainly not replicable. Why do you have to reboot? I presume the system's probably still reachable internally. What type of WAN? Gateway still reachable?

    type of Wan you mean what network card is used on the router?  i think it is a realtek.

    everything seems to work except for internet. i can still access the webui but SLOW. i have to ssh into it to reset the router then internet comes back.
    I'm working on a new router atm with intel 211 nics in it will try it on that also.

    Edit:

    i have a ISP router i cant disable the firewall from and cant put in bridemode and port forwards etc is very very limited. ( experiabox V10) and i put in that router a DMZ to my pfsense box.

    so i can do everything ( or almost) on my pfsensebox.

    edit2:
    it seems it is now beeing blocked and i get a green status so all is fine.

    i was playing with some settings of pfsense when it happens but that should not matter that much because i didnt change the settings back.

    Maybe it was just a coincidence that it happened i have no idea. But its good that the firewall worked. If i know more information or i can replicate it again i shall post about it.



  • @Music:

    type of Wan you mean what network card is used on the router?  i think it is a realtek.

    No I meant whether it's PPPoE, DHCP, static IP? Mostly curious if it was PPPoE, did the PPPoE stay up. But you answered that indirectly re: the modem. The type of NIC used won't impact anything like that. The web interface being really slow is probably just a function of DNS being unreachable and some part of it trying to resolve DNS and awaiting timeouts.

    @Music:

    Edit:

    i have a ISP router i cant disable the firewall from and cant put in bridemode and port forwards etc is very very limited. ( experiabox V10) and i put in that router a DMZ to my pfsense box.

    My first guess was the test was doing something that crashed your modem and something that happened in the process of the reboot of the device plugged into it fixed the problem.



  • @cmb:

    @Music:

    type of Wan you mean what network card is used on the router?  i think it is a realtek.

    No I meant whether it's PPPoE, DHCP, static IP? Mostly curious if it was PPPoE, did the PPPoE stay up. But you answered that indirectly re: the modem. The type of NIC used won't impact anything like that. The web interface being really slow is probably just a function of DNS being unreachable and some part of it trying to resolve DNS and awaiting timeouts.

    @Music:

    Edit:

    i have a ISP router i cant disable the firewall from and cant put in bridemode and port forwards etc is very very limited. ( experiabox V10) and i put in that router a DMZ to my pfsense box.

    My first guess was the test was doing something that crashed your modem and something that happened in the process of the reboot of the device plugged into it fixed the problem.

    well my internet it self is pppoe its KPN-Fiber (dutch provider).  but pfsense isnt directly connected to it.
    im just using the DHcp server. i get a IP from the ISP modem and then have the dhcp on pfsense enabled. The modem didnt crash internet was still working. i got my TV(IPtv) directly connected to the modem and that just continued so only pfsense itself was without internet. When i log in via SSH the wan IP is just gone. When i try to assign a wan IP again via dhcp it does not give any IP untill i reset the PFsense box.

    I run the own DNS server in PFsense i dont use the ISP DNS nor anything like google etc.


Log in to reply