XMLRPC : Invalid payload, corrected in 2.2.6 but persistant for pfblockerng



  • Hello,

    when i first set up my failover, i experienced issues with XMLRPC sync, which you corrected on the 2.2.6, and i thank you for this =)  (https://forum.pfsense.org/index.php?topic=102135.0)
    upgrading solved my issues

    I installed today pfblockerng, and it appears this package has the same issue you corrected (invalid payload)

    Has someone the time to have a look at this ?

    Jan 16 18:23:59 php-fpm[62387]: [pfBlockerNG] XMLRPC sync is starting.
    Jan 16 18:23:59 php-fpm[62712]: /rc.filter_synchronize: Beginning XMLRPC sync to https://XXX.
    Jan 16 18:23:59 php-fpm[62712]: /rc.filter_synchronize: XMLRPC sync successfully completed with https://XXX.
    Jan 16 18:24:01 php-fpm[54639]: /rc.filter_synchronize: An error code was received while attempting XMLRPC sync with username admin https://XXX - Code 2: Invalid return payload: enable debugging to examine incoming payload
    Jan 16 18:24:01 php-fpm[54639]: /rc.filter_synchronize: New alert found: An error code was received while attempting XMLRPC sync with username admin https://XXX - Code 2: Invalid return payload: enable debugging to examine incoming payload

    thanks in advance,

    olivier

    PS: I tried to attach a screen of the issue, i always get a 500 internal in every try…



  • I have exactly the same issue :( An error code was received while attempting XMLRPC sync with username

    Best,
    Rafal



  • We use pfSense version '2.3.2_1' and pfBlockerNG '2.1.1_4', we don't experience this issue, check you're on the latest version.

    If you're using a dedicated NIC for XMLRPC (recommended) you should use a cross-over cable and set the speed\duplex to 100base TX with static IPs.

    Enter the following settings for pfBlockerNG -> Sync (might be an issue with it using the generic settings):
    Enable Sync: Sync to hosts defined below
    Protocol: HTTPS
    Target IP/Hostname: backup pfSense IP
    Target Port: 443
    Target Password: your admin password

    We had a few problems when we initially built our environment on Broadcom NICs, we now use Intel.

    Hope this helps.