PXE boot / TFTP between different subnets



  • Hi,

    I have tried to move my TFTP server from my internal network to a DMZ subnet to make it accessible to both internal and DMZ machines. However I have problems getting any file transfers going, both manual and PXE boot.

    192.168.15.0/24 (Internal)
    192.168.35.0/24 (DMZ)

    • Internal has full access to DMZ
    • Connecting with TFTP client to TFTP server (192.168.35.14) works from both internal and DMZ
    • File transfer (get <filename>) works from other DMZ servers, but not servers on the internal subnet.

    I have tried enabling the TFTP proxy on both networks, but it does not make a difference. With the proxy enabled I get this in the system.log
    –------
    Jan 16 20:53:20 fw tftp-proxy[23279]: 192.168.15.11:55421 -> 127.0.0.1:6969/192.168.35.1:60119 -> 192.168.35.14:69 "RRQ pxelinux.0"
    Jan 16 20:53:25 fw tftp-proxy[23393]: 192.168.15.11:55421 -> 127.0.0.1:6969/192.168.35.1:55743 -> 192.168.35.14:69 "RRQ pxelinux.0"
    Jan 16 20:53:30 fw tftp-proxy[23394]: 192.168.15.11:55421 -> 127.0.0.1:6969/192.168.35.1:51346 -> 192.168.35.14:69 "RRQ pxelinux.0"
    Jan 16 20:53:35 fw tftp-proxy[25346]: 192.168.15.11:55421 -> 127.0.0.1:6969/192.168.35.1:62143 -> 192.168.35.14:69 "RRQ pxelinux.0"
    Jan 16 20:53:40 fw tftp-proxy[25359]: 192.168.15.11:55421 -> 127.0.0.1:6969/192.168.35.1:62728 -> 192.168.35.14:69 "RRQ pxelinux.0"
    –-----

    Assistance would be welcome.</filename>


Log in to reply