New Install, no internet access from pfsense (or lan) out WAN



  • Setup:
    Internet -> SB6183 Cable Modem -> Pfsense Router -> PC

    Pfsense:
    Version 2.2.6 amd64

    Pfsense hardware:
    Qotom-T4010P
    2 * Intel 82574L - 10/100/1000 Controller

    WAN:
    DHCP External IPV4 & IPV6 – 67.x.x.x

    LAN:
    192.168.1.1/24

    Issue:
    Originally I was having trouble pulling an IP on wan, through rebooting the modem and resetting to defaults I was eventually able to pull the DHCP lease from comcast. The setup is not complicated and by all accounts should be working. The WAN works fine when bypassing pfsense and going straight to my PC.

    I have tried swapping ports and interfaces, the LAN side works flawlessly each time (in connection to the pfsense box). The WAN side will pull its IP - but never get out. I have been able to ping some IPs ( 8.8.8.8) but there is always at least 33% packet loss if it pings at all.

    I am unable to access the cable modem as well, @ 192.168.100.1 when hooked into pfsense.

    Any help would be appreciated.

    I have taken screen shots of my settings below.



  • For some reason your pfSense partly knows that its IPv4 WAN IP is 67.166.247.39 with gateway 67.166.240.1 but status->interfaces is showing just the IPv4 gateway and no IPv4 address for the interface  ???

    The various settings for DHCP on WAN and… look OK. I'm not sure what to tell you to do, other than reboot! If you look in the logs early in the boot, it would be interesting to see what happened when DHCP was first received on WAN.



  • Thanks for the reply. I am baffled. I have done nothing different. Just kept swapping, plugging, rebooting. Now it works.  :o

    The only thing I can think of is, I had read a thread where the modem reaches out on an internal IP first to verify hosts. Every time during setup I left block private networks checked. This time I did not.

    Now to see if it works consistently.



  • Ran into the same issue on a fresh install of 2.2.6.  Appears to be a bug with the integration the of DNS Resolver Unbound - OR another DNS server on your network (was not my case).  I reinstalled 2.2.6 several times with no devices attached to the router and received the following similar message after first initial boot.

    Under your System Logs: General image, item 21 (5 up from the bottom), notice the following error:

    The command '/usr/local/sbin/unbound -c /var/unbound/unbound.conf' returned exit code '1', the output was '[1453028981] ... error: bind: address already in use [1453028981] unbound[54500:0] fatal error: could not open ports'
    

    If you want to resolve DNS you will have to Disable DNS Resolver (Unbound) and Enable DNS Forwarder (dnsmasq).  After that you should be fine.  I hope this gets resolved (no pun intended) soon.


Log in to reply