Force full XMLRPC sync?



  • Is it possible to force a full XMLRPC re-sync?

    Due to issues I have posted about in another thread, the master and backup nodes in my setup are massively out-of-sync.



  • Make a change on the primary and save, or go to 'high availablity sync' and save.



  • This doesn't work - just tired unchecking a few options in High Availability, then rechecking them. Doesn't work, nothing gets synced.

    In fact, all I get are error emails every 15 minutes or so.

    Considering flattening the lot and starting with a config backup. Something is very wrong.


  • LAYER 8 Netgate

    And the error emails say what?



  • Either;

    ​​An error code was received while attempting XMLRPC sync with username admin https://192.168.253.254:443 - Code 5: Didn't receive 200 OK from remote server. (HTTP/1.0 500 Internal Server Error)

    Or

    A communications error occurred while attempting XMLRPC sync with username admin https://192.168.253.254:443.

    The former appears to be a PHP crash - restarting PHP-FPM on the secondary clears this for a little while.
    The latter is the most common.



  • Just to add - I've re-entered the password just to be sure. Didn't make any difference.


  • LAYER 8 Netgate

    If you can't diagnose what's happening on your pfsync interface with any more detail I would consider rebuilding the backup from scratch and re-syncing fresh.



  • Quite hard to mess about while the system is in production. I've managed to secure a downtime window, so I'm gonna flatten both boxes and restore the config.

    I'll report back once it's done!



  • Okay, I flattened both nodes, reinstalled 2.2.6-RELEASE and then restored the config to the master, and just an XML with interfaces, gateways, CARP addresses and users to the secondary.

    After setting up pfsync and XMLRPC again, it seems to be alright, but I guess time will tell!


Log in to reply