Restoring backup onto new hardware, ran into problem



  • OK so hopefully long story short.. Been running pf on a Dell Optiplex and obtained a newer model to upgrade to.  Going from Core2Duo to I5 (yes I know it's not needed for a 10 device household but its free so…) so I built up the new box.. same number of nics and actually exact same nic chipsets.  A dual head Broadcom PCIe and a single Intel PCIe.  So I backup 'ALL' my existing box, put the new box into service and immediately notice that the dual Broadcom nics were not showing link even though the two DSL modems did.
    "Ok" I thought "Maybe it's because I need to restore".  So I did that.. restore went fine, rebooted and same thing.  The dual headed Broadcom refused to come up, and like I said above both of the ATT dsl modems showed link.  The nic LEDs show link.. just not pf.

    While flipping through the pages I notice that the Dashboard shows my old CPU.  Not the I5 but the C2D... something is not right.

    I had to remove that box and replace with the old one which fired up and worked perfectly.  I do not have many rules, no queues, VPN or anything like that.  So tonight Im planning on reinstalling the original and seeing if it sees all three WAN interfaces and go from there.

    Should it matter than I'm restoring 2.2 to 2.2.6?



  • Weird.. So I format and reinstall 2.2.6 on the newer Dell and toss it into production.  Setup the interfaces, all three WANs, the single LAN.. then setup teh routing group and assign that Gateway group to the default LAN firewall rules and BAM! back to 10+mb/s down.
    I installed the same packages as before now.. BandwidthD and now Squid3.. enabled and rearing to go.  Same Speedtest results.



  • Not sure if you've checked this already, but have you checked the speed/duplex on your NICs and compared this to the speed and duplex on the ports on the switch you're using? I've seen occasions when both NIC and port have been set to auto-negotiate, causing just this sort of issue.



  • Ive read this before, however no I did not check for a duplex mismatch.  For one thing the switch LEDs (Cisco SG300-10p) didnt change to indicate a mismatch, and neither did the NIC led's.  But even so, I guess it might be possible however I've never seen a mismatch not be indicated by the LED"s.  Usually one end is showing HD while the other FD.

    However if I run into this again I'll def verify.



  • Broadcom NICs?
    Hmmm, Don't like them much.

    But at least Dell (depending on model) make drivers (probably not relevant) and firmware updates easy.

    So go check and see if there is a firmware update available for the NICs.  (BIOS too, while your there).


Log in to reply