Static mappings are being ignored



  • Hi,
    I have pfsense 2.2.6 serving as a dhcp server to a few computers (about 10) and about 5 voip phones
    I've noticed that one computer (Windows 7 pro) and one voip phone (Cisco 504) kept getting same dhcp address even though I've specifically mapped static ip for their MACs.
    It took me a long time and many reboots to get it to finally map to the assigned ip.
    Anybody else had this problem?
    This started around pfsense 2.2.x (maybe 2.2.4?), never had this kind of problem before.



  • Delete the original address from the status page.



  • @chpalmer:

    Delete the original address from the status page.

    I would but the delete option is not there. Not for online devices anyway.
    I suppose I could turn off the computer or voip phone and then delete the dhcp lease.
    But why are mappings being ignored?
    If I map a MAC address to a specific IP, why would the dhcp server happily renew the same dynamic address and ignore my mapping?



  • Same problem here, static should have preference over any old dynamic lease.


  • Rebel Alliance Global Moderator

    ^ that is not how it works..  The client requests his old lease, his lease is still there so sure the dhcp server will give it out.

    You can get with the writer of the dhcp server if you feel it should be smart enough to say oh you have a reservation I can not give you the old lease you had with me, I can only give you this new reservation.  That sort of code is not a pfsense thing but a dhcp server thing.

    but guess you could put in feature request to allow pfsense gui to delete what it sees is a live.  But a simple solution is to just stop dhcp server, edit the lease file to remove your specific lease or just delete the lease file and let it rebuild.

    rm /var/dhcpd/var/db/dhcpd.leases