Could not setup receive structures. Reported Bug in 2011 (Solved)



  • OK, right now I'm a little PISSED!

    Not because there is a bug but because I had to use the stupid dumb piece of crap VI to edit the /boot/loader.conf to add a couple lines because of a "bug"

    Vi just makes me mad as hell. It's difficult to understand and impossible to get any commands from so you have no idea what the heck you are doing unless you go digging online to find the commands.
    Nano is WAY easier, it gives you a command list right at the bottom of the screen. So needless to say this vi frustration has just ruined me for the next few hours!!@!

    OK, so now for the problem!!!!

    I have a Supermicro Atom C2758 with a Intel Pro 1000 Quad port NIC installed. Installed is 16GB of ECC RAM.

    When I install the NIC I loose all network access to pfsense. No traffic, no DHCP, nothing. The only access I have is via the console

    I've edited the loader.conf file here is how it looks now…..

    autoboot_delay="3"
    vm.kmem_size="4335544320"
    vm.kmem_size_max="535544320"
    hw.usb.no_pf="1"
    kern.ipc.nmbclusters="1310720"
    hw.igb.num_queues="4"
    net.inet.tcp.tso="0"

    This same problem was reported back in 2011 found here
    http://redmine.pfsense.org/issues/1221

    I've reported the problem here which was changed from a bug to not a bug found here...
    https://redmine.pfsense.org/issues/5785

    I'm sorry but it sure seems like a bug to me when you can't even access the network interfaces with a quad NIC installed. I would have to pull the unit, pull the NIC and then tune. Problem is the tune settings I have are NOT working! I still don't have network access. Anyone else have any ideas, I'm all out.

    And don't tell me to look at https://doc.pfsense.org/index.php/Tuning_and_Troubleshooting_Network_Cards
    I've already done it, I didn't see anything that helped.



  • oh, and as a side note the up down beeps don't work for some reason on this board. The board beeps on post, but that's it.



  • OK, I seem to have fixed it myself.

    For anyone else that finds this post here is what I did and what happened…

    I changed the /boot/loader.conf to....

    autoboot_delay="3"
    vm.kmem_size="435544320"
    vm.kmem_size_max="535544320"
    hw.usb.no_pf="1"
    if_igb_load="YES"

    I edited /boot/loader.conf.local and it now contains the following....

    kern.cam.boot_delay=10000
    kern.ipc.nmbclusters="131072"
    hw.igb.num_queues=1
    net.inet.tcp.tso=0

    What happened was that when I installed the other NIC with the 4 interfaces on it igb0 and igb1 which are wan and lan moved from the motherboard interfaces to the PCIE interfaces.
    Basically the interfaces physically moved from onboard to the PCI Express card. Something I didn't realize until I started just moving down through the ports until I started seeing a ping on a interface on the PCI Express card.

    Further testing is required to determine if I'm getting the full capable speed of the cards.



  • Where ever you found num_queues=1, it's a really bad idea unless you want to make things unnecessarily slow. Remove that. Just follow what it shows on
    https://doc.pfsense.org/index.php/Tuning_and_Troubleshooting_Network_Cards
    which you should have correct after removing the queues limit.



  • Thank you for the reply. This has been frustrating but I will do just that. Thank you very much for the reply!!! :)



  • After all my fussing around my configs are as such….

    /boot/loader.conf
    autoboot_delay="3"
    vm.kmem_size="435544320"
    vm.kmem_size_max="535544320"
    if_igb_load="YES"
    kern.maxfilesperproc=32768
    kern.maxfiles=65536
    comconsole_speed="115200"
    hw.usb.no_pf="1"

    /boot/loader.conf.local
    kern.cam.boot_delay=10000
    kern.ipc.nmbclusters="1000000"
    net.inet.tcp.tso=0

    As a note to anyone else. If you add a card that uses the same driver/chipset that you already have your interfaces (in this case igb#) may very well move. In my case igb0,1,2,3 moved to 4,5,6,7 and the new card received 0,1,2,3.


Log in to reply