Boot FAIL on HDD



  • Hello folks
    yesterday i downloaded the latest version of pfsense x86 LiveCD everything was good but when i tried to install Pfsense to hard drive it shows up some errors and at the end it doesn't boot on HDD please see the pictures to understand what i mean



  • Looks like a disk error.  Have you tried a different hard disk?



  • @Aiker:

    … pfsense x86 LiveCD .....

    This means that you have some very old hardware.
    For harddisks (a things that moves and should be in shape) this means : end of live ….. and then he dies ....



  • i did change the Hard Disk and tried again but same old story  :-[ is there any chance



  • I had the same (or very similar) problem on my "brand spanking new" hardware of mine. It had to do with hardware incompatibilities. Eventually freeBSD development caught up and i managed to install fine!

    -What is your hardware? Give as some details.(Please!)

    -Are you using the correct edition of pfsense? (32b-64b)?
    -Is bios up to date?
    -Have you played around with bios settings?
    -Have you tried disabling stuff in Bios?
    -Have you tried out different HDDs, are you on SSD?
    -How large is your partition?
    -Have you tried nanoBSD?

    -edit
    Sorry i am little confused, are you talking about a new installation or did you have a working pfs box that is not working now?



  • Thank you for your quick reply actually my hard ware is a PC an HP Compaq DC7900 Convertible MiniTower with a core2duo VPro processor with 3 Giga of RAM with a Sata HDD Western Digital i downloaded the x86 LiveCD version of Pfsense i've already installed this to another computer and everything was fine i did nothing on the bios setup sets as default i have no partition i dedicate the entire disk 160giga for pfsense i didn't tried nanobsd for the update of the bios i don't think it is up to date
    thanks



  • I am not familiar with your model but…

    Is the "other" computer the same model and make as the one that gives you the trouble now? If yes!
    Are the bios versions the same?
    Are the bios settings identical?

    Is the partition(or HDD) on the "other" as big as the one that gives you the trouble now?
    You could try and make a partition of 10GB and try to install on that one.

    Have you done a memtest to see if your ram sticks are healthy?



  • yes i did all of this and no the other computer was a dell optiplex anyway i'll change the pc and see if the problem still exist and btw the other pc i installed on it 2.2.5 but now i'm trying with 2.2.6



  • try 64bit, its generally better if your hardware supports it … and it probably should as its probably a c2d e8400 or something better.



  • ok i'll try the 64bit thanks guys i appreciate your help



  • thank you, i had the same exact problem, and running 64 bit installation fixed the issue. Thanks!



  • You also might want to check your BIOS' disk options, IDE vs AHCI, and see if that helps at all if the amd64 build doesn't fix it for you.  Wouldn't hurt to check for any BIOS updates for that hardware, and reset it back to factory defaults as well just in case something got changed over the years.


Log in to reply