Native IPv6 with Deutsche Telekom / T-Online



  • Hi,

    since I got a "new" contract, where I can get a native 2003:: Deutsche Telekom IPv6 network, i tried to replace my working 6to4 solution, which does not make any sense any more since i don't have
    a static IPv4 Adress (and so, I don't have static IPv6 Adresses resulting from the 6to4 translation….)

    But: I cannot get it to work.

    AFAIK T-Online uses pppoe for the IPv4 Adress and then a IPv6 Prefex is acquired by DHCPv6.  I try to get a /56  Range as well as a /48 or /64 Adressrange but nevertheless - after a couple of seconds only a
    local link Adress is displayed - or no IPv6 Adress at all...

    I doublechecked my Accesscredentials with a German Fritzbox, and that works out of the box with IPv6 with the following (AVM simplified) config option:  "Falls per DHCP ein 6RD-Server gelernt wurde, wird ein 6RD-Tunnel aufgebaut. Ansonsten wird versucht, eine native IPv6-Verbindung aufzubauen (Dual Stack)."  (In English: If a 6RD server was learned via DHCP, a 6RD tunnel is established. Otherwise, an attempt is made to build a native IPv6 connection (dual stack)."

    So.... I don't see any progress... Any hints what I should try? Is German Telekom really using DHCPv6 or  is it something different like 6rd or ppp-ipv6 or something like that?

    Thanks a lot for your help!

    Cheers,

    4920441



  • This post might help (some German language here):

    https://forum.pfsense.org/index.php?topic=103689.msg580111#msg580111

    (Although I was not successful with that myself.)



  • Hi,

    did not work for me either…. I tried it just one time copying the mentioned configuration

    Don't know what the problem is - in the log file I see there :

    Jan 23 11:51:22 ppp: [wan] IPV6CP: LayerStart
    Jan 23 11:51:22 ppp: [wan] IPV6CP: state change Initial –> Starting
    Jan 23 11:51:22 ppp: [wan] IPV6CP: Open event
    Jan 23 11:51:22 ppp: [wan] IPV6CP: SendConfigReq #1
    Jan 23 11:51:22 ppp: [wan] IPV6CP: state change Starting –> Req-Sent
    Jan 23 11:51:22 ppp: [wan] IPV6CP: Up event

    But  then:
    Jan 23 11:51:22 ppp: [wan] IPV6CP: LayerFinish
    Jan 23 11:51:22 ppp: [wan] IPV6CP: state change Req-Sent –> Stopped
    Jan 23 11:51:22 ppp: [wan] IPV6CP: protocol was rejected by peer

    …so, if I didn't try it myself with a FritzBox and got myself a 2003::  address, I'd say the login data isn't capable of native IPv6....

    Any other hints?

    Cheers

    4920441


Log in to reply