TinyDNS problem



  • Hi, I have some problems with an old pfSense 2.1 server.
    In past we installed some packages, one of them was TinyDNS which we used with a couple of internal domains.
    One day I noticed some upgrades on this package so I tried to upgrade using the pfSense interface, the upgrade was a huge mess (honestly I only remember it was blocked) so I tried to uninstall it, reinstall and reconfigure from scratch.

    The installation didn't work and also pfSense didn't work (no dns resolution from public dns, no routing, no vpn), so I decided to restore a backup.
    After the restore pfSense start to work again but every firewall or vpn change (for example a new rule or nat, or ipsec tunnel) do not work.

    I suspect the cause of these problems is some piece of TinyDNS still on the system, for example if I make a change in firewall rules and click the apply button, looking to the filter reload status page I noticed this message: Checking for nat PF hooks in package /usr/local/pkg/tinydns.inc…

    Searching for 'tiny*' files on all the filesystem I found these:

    [2.1-RELEASE][root@fw.local]/root(22): find / -name 'tiny*'
    /usr/local/www/tinydns_status.php
    /usr/local/www/tinydns_dhcp_filter.php
    /usr/local/www/tinydns_filter.php
    /usr/local/www/tinydns_view_logs.php
    /usr/local/pkg/pf/tinydns_xmlrpc_sync.php
    /usr/local/pkg/tinydns.xml
    /usr/local/pkg/tinydns.inc
    /usr/local/pkg/tinydns_domains.xml
    /usr/local/pkg/tinydns_down.php
    /usr/local/pkg/tinydns_up.php
    /usr/local/pkg/tinydns_parse_logs.php
    /usr/local/pkg/tinydns_sync.xml
    

    Is there any way to completely purge TinyDNS on the system?
    I also want to upgrade pfSense, but with this problem I'm not sure it's the best move, I prefer to solve this problem and return to a normal scenario before trying the upgrade.

    Thanks for any help

    Tas


Log in to reply