DynDNS for Private IP



  • DynDNS service trying to find public IP and send it to DynDNS service provider. I want to send my private IP. I don't want to determine the public IP.
    Is there a easy way?


  • LAYER 8 Global Moderator

    For what possible reason would you need to resolve a private IP publicly for - you sure and the hell can not route it anywhere.

    If you want to resolve a private IP, then you resolve it locally..



  • @johnpoz:

    For what possible reason would you need to resolve a private IP publicly for - you sure and the hell can not route it anywhere.

    If you want to resolve a private IP, then you resolve it locally..

    How can I do?
    I must change codes, do I?


  • LAYER 8 Global Moderator

    huh?  Dude I am not going to help you put rfc1918 space into a public dns.. Its BROKEN setup..

    You can dynamically register your devices local private IPs with your local dns..



  • I think we're talking about different things.

    My pfsense's WAN interface ip is 192.168.1.100.
    My subdomain test.domain.com at freedns

    I want this: test.domain.com = 192.168.1.100 with Dynamic DNS updates.

    Can I do it with Custom serivce or I must write a php script and add it cron?


  • LAYER 8 Global Moderator

    "I want this: test.domain.com = 192.168.1.100 with Dynamic DNS updates."

    And that is BROKEN!!!  Why would you want or need such a thing??  You can not get to 192.168.1.100 from anywhere other than your local network.  So registering that in freedns or any other public dns dyn or not is completely POINTLESS and a BROKEN setup..

    What you want is for your actual public IP… Go to whats my public IP and see what that is, that is the IP address you want to publish, so when your away from your network or need for someone to connect to pfsense they would use your actual public IP..



  • It's not broken setup. You don't answer my question, you offer a different thing.
    I wan't use private ip on public dns.

    I know what I want. I do not know how I can do.


  • LAYER 8 Global Moderator

    "I wan't use private ip on public dns."

    And that is BROKEN!!!  There is NO Point in doing that - NONE!!!  Please give example how it makes sense for public dns to resolve to a private IP address…  There isn't any!!  There is NO point for anyone other than your local machines to resolve that IP..  So using your local dns you resolve it..

    Public domains responding with rfc1918 address is how rebinding attacks work - are you wanting to do a rebinding attack?



  • If I don't use local DNS?


  • LAYER 8 Global Moderator

    And why is that?  pfsense can be dns, any soho router can be dns.. So put that 192.168.1.100 in your host file then..

    Public dns is not the place for rfc1918 address space.. Pfsense runs unbound in resolver mode out of the box - why would you turn it off?



  • @johnpoz @Resolute

    I have also the need to update a ddns with a private IP.

    Why? Because my PBX needs to know which is the current IP for my private link between my pfsense and my ISP, for SIP-NAT purposes.
    The link uses a dynamic private IP address, so anytime my provider changes my pfsense's private IP, I have to go to PBX settings and update it manually.

    DDNS for private IP addresses is not broken, if you just didn't find a use for it doesn't mean it's not needed for some of us


  • LAYER 8 Global Moderator

    @gabrielpc1190 said in DynDNS for Private IP:

    , if you just didn't find a use for it doesn't mean it's not needed for some of us

    Your DOING it WRONG!!! Period!!! Plain and simple there is ZERO reason ever to do this at an enterprise level... If your are doing it to access your plex server or something.. sure ok.. but that is not in public dns, that is in a private domain plex.direct that only plex users use, etc..

    And even then for that to work, the local network has to disable rebind attacks for that domain or it doesn't work!!

    Your local clients can resolve rfc1918 just fine... But don't expect public ddns to allow for rfc1918 - since that leads to rebind attacks..



  • @Resolute said in DynDNS for Private IP:

    It's not broken setup. You don't answer my question, you offer a different thing.
    I wan't use private ip on public dns.

    I know what I want. I do not know how I can do.

    You said your WAN address was 192.168.1.100. That's one of the RFC 1918 addresses, which are not routeable over the Internet. Your ISP is using NAT to share public addresses with multiple users. This means it's impossible for anyone to reach your WAN. This also means there is no point in using dynamic DNS to point to it.

    Your ISP is using NAT because of the shortage of IPv4 addresses. The only solution is for the world to move to IPv6. Anything else, such as NAT, is a hack that causes problems such as yours.



  • FreeDNS accepted my RFC 1918 ....

    47333ff8-58e0-4f8e-a871-0271bfc9c7c3-image.png

    Let's check :

    root@ns311465:~# host brithotelfumel.mooo.com
    brithotelfumel.mooo.com has address 192.168.1.100
    

    Oh ..... lol.

    edit :

    It can be done.
    Look :
    74afeab0-d0f8-4d50-be0a-46a047c8d430-image.png

    Up to you to write the file some_script_page_that_returns_the_RFC_1918_IP.php and place it in the webroot of the GUI.

    Please note :
    Your PHP script should return a phrase like this :

    		preg_match('=Current IP Address: (.*)</body>=siU', $ip_result_decoded, $matches);
    

    Check for yourself : click on http://checkip.dyndns.org/ and see what is returned ^^

    Found this :

    		// Use the first enabled check IP service as the default.
    

    which means that your code will get used for all "IP checks" now. The default

     	http://checkip.dyndns.org
    

    won't get used any more. Which implies : no more classic real non RFC 1819 any more. So you have to code a solution for this yourself.

    So, it's as usual : yes, pfSense can even launch your nukes. As soon as YOU are able to tell him how to do so.

    I can understand that the pfSense GUI doesn't support RFC 1819 type of IP's here as should cause problems in 99,9999 % of all cases.


Log in to reply