PfSense nanoBSD halts on boot



  • –----- resolved-------

    Hi there,
    I am new to pfsense and I encountering a very strange issue on boot.
    Setup:
    Dell E4200
    No HDD
    NanoBSD on USB Stick
    pfSense 2.2.6

    When the system boot, I can see the pfSense Boot Option Menu. If I do nothing, or press #1 Boot Multi User or #2 Boot Single User the system just halts. No messages at all.
    However, if I do the following:
    Press: #3 [Esc]ape to loader prompt
    Type: boot-conf
    And press enter after boot-conf finishes the system boots just fine.

    Everything else seems to be working fine. I was able to set both ipv4 and v6 over PPPoE and route the traffic successfully.

    Any ideas how to fix the boot?



  • I tried just typing boot on Loader prompt and the system boots fine. Meaning that there is no need to run boot-conf.

    Any idea what can cause this, or how ti simulate that behavior during boot automatically?



  • No-one? Not even a tip?

    Is it possible to make the default boot option the Loader Prompt?



  • Looks like I've solved the issue.
    In my case I had to disable beastie from boot.

    My /boot/loader.conf.local is as following
    loader_delay="9"
    beastie_disable="YES"

    Already rebooted few time and works like a charm.

    Also I encountered the same issue using USB HDD and Full Pfsense install -> did it to troubleshoot. That makes me lean towards some wiered USB controller issue and beastiie.