Access by hostname, not by IP address



  • 2.2.5-RELEASE (amd64)

    I am new to pfSense and networknig.

    We have Cisco NAS in VLAN1 (192.168.1.20/24), and the host name is "cisco"

    From computers in VLAN1, they can access to the Cisco NAS by "\cisco" on Windows or "smb://cisco/" on Mac.

    However, from the other VLANs (ex. 192.168.2.0/24), access by host name does not work. They have to type \192.168.1.20\ or smb://192.168.1.20/

    I added the host name, domain and IP in "Host Overrides" under DNS Fowarder, but it did not work.

    Am I looking at different setting, or am I supposed to change anything else?

    Thank you.


  • LAYER 8 Global Moderator

    Are you using the forwarder?  New versions of pfsense use the resolver by default.

    So if you setup a host override for cisco.yourdomain.tld then your clients using that dns should be able to hit smb://cisco.yourdomain.tld

    This is simple enough to verify with simple dns query.


Log in to reply