USB Flash drive wont boot



  • I am trying to install pfSense onto a USB flash drive and after it finishes, the computer won't boot to the flash drive. I have tried it inside of VMware and 2 computers so I'm sure that it's probably the type of flash drive I'm using. It's a mini TD Memorex drive (2GB). I have tried with and without Grub, boot blocks, and packet mode and it doesn't seem to make a difference. When I try in VM, it just says there aren't any bootable devices and when I try on one of the computers, it just freezes when it would normally start the boot to CD or Harddrive etc. I have a live OS on another USB drive that I know works. Are there any known bugs with the way that the mini TD is formatted by BSD?



  • Does the drive have a bootable partition?



  • It does, and apparently I just got really unlucky on the batch of computers I chose to test with. I went through the BIOS and disabled everything from serial to parallel and audio, and it seems to boot now. I'm pretty sure ACPI was already disabled but now it looks like it boots and is running fine. I'll try with the other ones and see if I have the same fix. I walked the virtual BIOS for VMWare but I didn't find any settings for that. Thinking back, I've used VMWare to prep USB flash drives for deployment, but I don't think I ever booted to them in VMWare after the install.


Log in to reply