Potential DNS Rebind attack detected, unable to solve it



  • I have googled and tried everything it seems like, but I still can't solve this problem.

    I have a webserver on the same network as pfsense. I have port forwarded port 80 to the webserver on the internal network. Accessing the webserver from the outside works just fine, but from inside the network I only get Potential DNS Rebind attack detected error messages. And certificate errors.

    I have tried NAT reflection as suggested, adding the domain to "hosts".

    If I disable that DNS check completely it gives me an 404 error.

    Any ideas? I use the latest pfsense version.



  • Set your internal DNS to resolve the web server to it's internal address. That way your internal hosts don't have to hit the firewall just to access a machine sitting right next to them, and you'll probably find all the other errors will resolve also.

    There have been many, many posts on this forum about problems with NAT reflection. Best to avoid it if at all possible.



  • Sounds reasonable, I will try that.