Install of 2.2.6 on 32gb eMMC Nand



  • Hi guys, i am trying to install v 2.2.6 on the following hardware

    Acer Revo m1601 | 2GB Ram, 32GB eMMC NAND

    Full description off ebuyer here - http://www.ebuyer.com/723607-acer-revo-m1601-nettop-dt-b2aek-003

    When i first boot i get ACPI error which after googling found that i can disable ACPI in the PFSense boot menu. Doing this however caused the kernel to panic and halt with error "unning without device atpic requires a local epic"

    So i enabled ACPI again and allowed to continue to boot continuing to get errors about ACPI but also AE_NOT_FOUND.  Once i got the main menu i selected option 99 for HDD install however it can't locate the SSD and states it requires drivers.

    I have searched the web but can't find any reference to this or how to fix. Can anyone help??

    Thanks in advance



  • I have the same machine, I got pfSense 2.2.6 installed on the machine by using a usb3 cloning dock, one hd had the installer image on it, and I installed pfSense to the other hd.

    I did this because same as liamarmitage, I couldn't find the eMMC, and then I wanted to test if there was any other hardware problems, and there was, or at least for me, my Revo shipped with the Intel 3165NGW Mini NGFF wifi card, and currently there is no firmware for that in FreeBSD 10.1, I read some were that it should be supported in FreeBSD 11, but thats not going to help me right now. So I took the card out and now I'm looking for a supported replacement. The Revo shipps with 3 different wifi cards, so maybe you wont have this problem.

    But I'm also looking for a possible solution to the eMMC problem, but if that cant be solved right now I'll settle for a usb drive or sd card install, when I get my LAN Interface up and running on the box.

    Here is some more information about the box:

    The ACPI error that is mentioned in the OP is spammed to the terminal every 4 sec. looks like this:

    ACPI Error: [TCNT] Namespace lookup failure, AE_NOT_FOUND (20130823/psargs-393)
    ACPI Error: Method parse/execution failed [\134_TZ_.THRM._PSL] (Node 0xfffff8000341a680), AE_NOT_FOUND (20130823/psparse-553)
    

    To get rid of that, you can set the variable that turns off ACPI thermal monitoring for your CPU at the Boot prompt.

    set hint.acpi_tz.0.disabled="1"
    

    It's really annoying to do the install when the terminal is spammed with that message all the time, so that helps a lot.

    You can then later go in to the web gui and turn on cpu monitoring from System> Advanced> Miscellaneous Menu under Thermal Sensors Choose coretemp and pfSense will show your cpu temp. And there is a system that manages your cpu fan so that it wont overheat, or at least my box turns on fan the when the temp rises to 50 C.

    So I enabled ssh on the box and then I ssh'd in from the WAN Interface, and took a look at dmesg, pciconf -lv and sysctl -a,
    here are the pastebin's from those:

    Acer Revo M1-601 B dmesg

    Acer Revo M1-601 B pciconf -lv

    Acer Revo M1-601 B sysctl -a

    Those pastes are before I sftp'd in to the box and edited /boot/loader.conf.local so that I dont have to set the variable every boot and then I also disabled the sound cards, looks like this:

    kern.cam.boot_delay=10000
    
    # ACPI thermal monitoring for CPU
    hint.acpi_tz.0.disabled="1"
    
    # Turn off sound
    snd_driver_load="NO"
    
    

    I know that this is not what you asked for, but here is some more information, so that if some one who has more experience dealing with pfSense hardware issues, likes to take a look at the logs, maybe they can tell why the eMMC is not showing up.

    Also I did a dd copy and wipe of my eMMC from a live Debian before I tried to install pfSense on the box.
    Thats some thing to think about, if you ever want to sell the box. Then you can dd copy the original image back to the eMMC, and when it boots up, it's like the first time, new, out of the box.

    And that tells us that the eMMC works under Debian, but I had to give some additional boot parameters to get it to boot Debian. I think this was the line I used:

    edd=off noapic nolapic acpi=off
    

    So if anyone have any ideas how to trouble shoot this I'm open for suggestion, I have the box here and I can ssh in to get more information.



  • Hey vcd really appreciate the lengthy reply and will try out your suggestions this weekend.

    Hopefully I can at least get it installed as you have and use the thing.

    Thanks again