Please help with WAN configuration



  • I seem to be going round in circles getting the WAN interface configured…. I have my Internet access provided my Virgin Media via a cable modem which has been set up in Modem Mode. It has a fixed IP address of 192.168.100.1. In modem mode DHCP is disabled so I guess I need to use a static IP address for the WAN interface.... If I'm using 192.168.1.1 as the LAN interface what should I use as the WAN IP address, and what should be the gateway address?

    Is there anything else I should specify?

    Apologies for the dumb questions, but I managed to get my LINKSYS router up and running with minimal effort - it just worked. I can't figure out what I need to do to get the WAN interface of pfSense working at all...



  • You can use anything in the same subnet at the modem, just not the same IP address.  Try 192.169.100.2 for WAN with 192.168.100.1 as the gateway.  Double-NAT isn't the best way to go but you may have no choice if you can't get the modem into bridged mode.



  • I can ping the modem from the pfSense router and I can access the web configurator from my laptop, but can't seem to get Internet access… Seems as though I can't stumble upon getting the gateway configured properly.



  • I can ping the modem from my laptop so routing from laptop via router to modem works but there is no access beyond the modem.

    Have I blocked access to the Internet from within pfSense unwittingly?

    Do I need to specify the external IP address of the modem somewhere?

    Sorry for all the questions but I don't seem to be making much progress.


  • Rebel Alliance



  • Thanks for the pointer, but I have a very basic problem…

    
    Check that the WAN IP address is correct (Interfaces > WAN)
    - Using the wrong address could cause a failure of the ISP to deliver traffic to/from the firewall, among other issues
    
    

    I'm not really sure what to set the WAN IP address to. If I set the type to DHCP should I expect the modem to provide an address? I tried that but got 0.0.0.0.

    I have noticed that when using my LINKSYS router the WAN IP is set 92.239.173.103. This gets set automatically by DD-WRT. Should I expect something like this with pfSense?



  • Absolutely, yes!

    How was your Linksys device's WAN interface set up? DHCP or PPPoE or … ?
    Set the same in pfSense and it should work as well.

    BTW: Since 92.239... is a public IP your modem seems to be in bridge mode, passing the WAN traffic to your router. That's the preferred way of doing it.



  • I can ping the modem from the pfSense router and I can access the web configurator from my laptop, but can't seem to get Internet access… Seems as though I can't stumble upon getting the gateway configured properly.


  • Rebel Alliance Global Moderator

    Dude reset your modem (power cycle) when you connect a new device with different mac.

    If your old router was dhcp, then pfsense would be dhcp..  But you almost ALWAYS need to power cycle a cable modem when you change the device connected to it.

    Set pfsense wan to dhcp.  Power cycle your modem and then reboot pfsense - do you get an IP?



  • Thanks for all the suggestions everyone made.

    I do have my pfSense router working now, but the problem stemmed from the Virgin Media Superhub not providing an IP address initially. I rebooted countless times and wasn't sure how things were supposed to work.

    Thanks to some advice I received elsewhere I put the VM hub back into router mode, connected up my cables ensuring that the cable from the WAN NIC was connected to port 1 on the hub and re-enabled modem mode. This time the WAN IP address was immediately assigned when the hub rebooted.

    So now I am at the start of my voyage of discovery with pfSense :)


  • Rebel Alliance Global Moderator

    "immediately assigned when the hub rebooted."

    Yeah the power cycle when you went to back to router mode vs modem mode is prob what did it..



  • I don't think so since I power cycled about a dozen times. I think it was something to do with the WAN IP address had already been assigned to my LINKSYS router when I first went into modem mode.