Stuck on 2.1.5 release - no upgrades since worked ???



  • I have a LinITX ALIX 2D13 LX800 (3NIC+USB) pfSense Firewall Kit from linitx.com which runs on a Geode LX 800 (x86) CPU.
    My pfsense says the following:

    
    Version 	2.1.5-RELEASE (i386)
    built on Mon Aug 25 07:44:26 EDT 2014
    FreeBSD 8.3-RELEASE-p16
    
    Update available. Click Here to view update.
    Platform 	nanobsd (1g)
    NanoBSD Boot Slice 	pfsense0 / ad0s1 (ro)
    CPU Type 	Geode(TM) Integrated Processor by AMD PCS 
    
    

    Just noticed that the platform should really be "nanobsd (4g)"? Since I have a 4GB Kingston flash card on the board? Should I flash this with a 1g or 4g update? Can a upgrade take it form an insatlled and running 1g to a 4g layout in-place?

    My problem is:

    This firewalll has been running fine for 2+ years and gone through a couple or more updates without any problems in the past.

    But ever since the 2.2.x series came out all my attemps to update have failed, but in a very peculiar way.
    I have tried 'in place' upgrades. and upgrades from backup config with and without RRD data. And even from a 2.2.x pre-flashed flash card, and then loading the backup without RRD data.

    But in every combination, the system comes up and runs OK for about 9 - 12 minutes. Then I can still acces the management portal, but all clients, both wired and wireless loose the internet. and if a issue a restart the system sometimes came back up once or even twice, but never connected to the internet and at latest on the 3rd reboot, no longer even restarted.

    If I run the hardware with the standard config it runs fine for hours, but of course that way I don't get internet connection, so that test probably doesn't say much.

    If I load my config but have all the LAN and WAN cables disconnected, it also runs for hours, no problem. But as soon as I connect WAN and LAN it dies within 9 - 12 minutes of it.

    How can I debug this?

    I have a dd backup of one of those times, when it no longer booted after second or third restart attempt.

    Is this something I could pay a per instance support for? Really desperate to get this installation updated?



  • Connect a serial NULL cable and take the console 115200. Start from scratch on a fresh new CF with 2.2.6 nano(32)install (2g). Config the Ifaces anew. At last import your 2.1.5 config.xml. up in the GUI.


  • Netgate Administrator

    You should be able to do that upgrade without any particular issues.
    You should definitely be able to do it if you use a freshly flashed CF card.
    You should use the largest image that will fit on your card. Some 4GB cards are actually smaller and won't take the 4G image. If it writes to the card without error though you should be good.

    Did you try running 2.2.X without restoring your previous config for any length of time?

    The biggest issue with those older ALIX boards is that they only have 256MB of RAM which is restrictive. I suspect that you have some packages loaded that are exhausting the memory. The system logs should show that though or the console output if you have the serial console hooked up.

    What USB device are you using there? It's possible something in the FreeBSD 10 drivers is having an issue with it. Logs should also reveal that.

    Steve