M1n1wall factory reset?



  • Hi all,

    I have a black netgate m1n1wall that I was handed and told to configure, but I have no idea how to actually get into it. According to the user guide, the LAN interface should be set to 192.168.1.1 (assuming /24), however if I set my IP to 192.168.1.2/24 and try to connect to it over http, there is no response. Alright, so moving on - I have a usb to rs232 cable that I hooked up to it, set it to various baud rates (38400, 115200, 9600) 8n1, but no text. OK cool. So there's a pinhole on the front of the box for what I assumed is a reset function. I've tried holding it in for various lengths of time - immediate push, 10 seconds, 30 seconds, 1 minute - and no dice.

    Anybody got a clue on this thing? It lights up. I've tried sniffing on the LAN interface with wireshark in promiscuous to try to catch a rogue broadcast or something, but nothing. I'm out of options from my knowledge.

    Halp!

    Edit: so I actually got it to give me some output, however the only thing I get is "No boot device available, press Enter to continue". So… I guess I'll work on that.



  • That should be the same hardware: https://vimeo.com/149681504
    If your CF card isn't recognised anymore just use a new one and flash the nanoBSD image.



  • So… there is no CF in it at all. I'm assuming this may be an issue.


  • Rebel Alliance Developer Netgate

    @jardoin:

    So… there is no CF in it at all. I'm assuming this may be an issue.

    Indeed that would be the case.

    You'll need to track down a CF, 4GB or larger, and write out the NanoBSD image to it. Plenty of docs on the wiki for that.