It should work (Routing to a different Net)

  • Hello,

    I am trying to route to a different Net, but somehow something is missing.
    I need to access the server.
    Ping to the  the is fine.

    Here is my Netplan

    LAN /24 –------( pfSense WAN
                                                                                                                            default GW (router) ----- ISP
                                                                                                                            GW router ------ VPN------
    The default traffic goes trough the default GW.

    The following static route I created under System -> Routing: with the as GW.

    I thought this is enough. When I traceroute the dafault GW appears as the first hop.

     1  (  0.518 ms  0.405 ms  0.925 ms
     2  * * *

    Shouldn't the GW apear as the first hop?


  • LAYER 8 Global Moderator

    what do your lan rules look like..  if you want a lan device to get to this other gateway on your wan, you have to allow it to use that gateway.

    Where are you tracing from? Pfsense?

  • Yes, I am tracing from pfSense.

    As GWs I have the default GW
    and the GW which I want to youse the net

    As a route I have:
    network with the GW over the pfSense WAN interface

    My thoughts are:

    • The doensn't know the way back to my LAN.

    • But shouldn't tracing show the following hops:
        - (pfSense WAN Adress)
        - (Router to the network which I am able to ping)
          instead of the the IP of the default GW


  • LAYER 8 Global Moderator

    Why would your trace show your pfsense wan IP???

    Where are you lan rules???

    A trace always shows the hops as you hit them… So from your lan would be, then

    As to 116.220 yes it would need to know how to get back.. But that would have nothing to do with your trace showing you what the 2nd hop is..

  • I am tracing from pfsense.

    What do you mean with LAN Rules?
    I test often with the FW turned off.

    So when I trace the 10.112.220 the GW should apear as the first hop.

    Is my route wrong?

    In System -> routing I:

    • Configured my two GWs on the WAN Interface and the is the default one.
    • then I clicked on the "Routes" tab and configured the route: 10.112.116/0./24      GW: my second GW      interface: my WAN interface

    is there anything else to be done?


Log in to reply