Local domain name added to dns queries



  • I setup a new pfSense (2.2.6) with the DNS resolver and DHCP on the pfSense.

    The pfSense name is pfsense.home.local

    In the DHCP options the DNS server section is blank, so DHCP is giving out the pfSense as the DNS server. Also on the DHCP options the domain name entry is blank so per the page: The default is to use the domain name of this system as the default domain name provided by DHCP.

    The DNS resolver is configured to enable DNS forwarding and OpenDNS IPs are configured on the System General Setup.

    DNS lookups work just fine on Diagnostics DNS Lookup.

    When I do a DNS lookup on my computer which got its IP info from DHCP it is adding home.local to every lookup. So nslookup google.com attempts to lookup google.com.home.local and fails.

    If I manually change my DNS to OpenDNS or Google DNS on my computer it works ok.

    How can I prevent the DNS resolver from adding the local domain name of the pfsense to dns queries?


  • Rebel Alliance Global Moderator

    and yet again another .local - this is BAD, apple stole it and would not suggest you use that..

    "The DNS resolver is configured to enable DNS forwarding"

    Why??  If your just going to forward why not just use the forwarder?

    What version of nslookup are you using, just do nslookup google.com. <–-- add the final .  Or yes its quite possible to add your connections specific suffix or your search suffixes..



  • @johnpoz:

    and yet again another .local - this is BAD, apple stole it and would not suggest you use that..

    "The DNS resolver is configured to enable DNS forwarding"

    Why??  If your just going to forward why not just use the forwarder?

    What version of nslookup are you using, just do nslookup google.com. <–-- add the final .  Or yes its quite possible to add your connections specific suffix or your search suffixes..

    I didn't know .local was bad. What should I be using instead? (I don't have a public domain name I want to use for this)

    The DNS resolver has an option for DNS forwarding, and since it was made the default I assumed it was ok to do this. It's one click/checkbox vs disabling the DNS resolver and enabling/configuring the DNS forwarder.

    I am not sure what version of nslookup I am using (I am on an up to date Macbook). nslookup isn't necessarily the issue, but no domain resolutions seem to work (ie opening a web browser and trying to go to google.com doesn't work as it can't lookup google.com properly)

    I am not sure what you mean to add my connections specific suffix or my search suffixes?


  • Rebel Alliance Global Moderator

    use anything other than .local, say .lan or .locallan etc..

    https://en.wikipedia.org/wiki/.local

    Yes the resolver is the default now, in resolver mode…  If your just wanting to forward the forwarder does a better job if you ask me... It will forward to all your configured dns and use the quickest response, unbound does not do this..  Do you want/need dnssec to where your forwarding?  Does the dns you forward support dnssec?  Then sure you would need to use unbound for that.

    Put a . on the end of your query for nslookups - it is very common for it to do that..

    So as you see in first attached pic, I don't use . at the end of my query and it adds my .local.lan to the query..  then it walks up the tree and asks without my suffix.. And gets a response.

    When I just at the end saying DONT add my suffix searches..  While other tools don't auto use your suffix, see 3rd pic when doing it with dig

    So your on OS X - the doc for your nslookup even tells you to look up stuff not in the local domain to add a .

    https://developer.apple.com/library/mac/documentation/Darwin/Reference/ManPages/man1/nslookup.1.html

    To look up a host not in the current domain, append a period to the name.








  • Thank you for the explanation. This has been driving me bats.