Relatório Sarg ou Lightsquid por Usuário



  • Fala, pessoas.

    Tenho rodando a versão 2.2.6 do Pfsense com Proxy Transparente + Freeradius2 + Squid3 + Squidguard + Sarg.

    Está funcionando perfeitamente com usuários se autenticando pelo Freeradius e com geração de logs. O problema é que não consigo mostrar nos relatórios do Sarg o nome dos usuários ao invés dos ips.

    Instalei o Lightsquid para ver se conseguia essa resolução, mas nada. A impressão que tenho é que os usuários não estão sendo gravados no log. Somente está sendo gravado seus ips, o que pra mim não é interessante já que não estou utilizando ips fixos.

    Alguém sabe como posso fazer para resolver isso?

    Vlw



  • Olá Bom dia!

    A opção, convert Ip adress to dns Name está marcada em Report options nas Configuracoes do Sarg?

    Não sei se é viável, mas marcando essa opção que falei e indo em Users> Users Association é possível associar o ip a um usuário,

    Nunca utilzei essa função, mas taLvel ela te ajude!

    abraços

    Diego



  • @didonsom:

    Olá Bom dia!

    A opção, convert Ip adress to dns Name está marcada em Report options nas Configuracoes do Sarg?

    Não sei se é viável, mas marcando essa opção que falei e indo em Users> Users Association é possível associar o ip a um usuário,

    Nunca utilzei essa função, mas taLvel ela te ajude!

    abraços

    Diego

    Bom dia, Diego.

    Acabei de fazer isso que você sugeriu e de fato o nome do usuário apareceu, porém só consigo deixar assim para ips fixos. Possuo máquinas com ips fixo e vou utilizar essa sua ideia. Porém essas máquinas eu tirei da autenticação, logo consigo fazer por esse modo. Mas possuo rede wifi onde cadastro os usuários para se autenticarem depois. O problema é que o ip é atribuido pelo DHCP à esses usuários. Por isso eu gostaria de gerar relatório pelo usuário autenticado ao invés do ip.

    A não ser que para cada cadastro de usuário eu atribua um ip. Mas sei não! Deve ter uma forma mais simples de tratar isso sem ter que cadastrar ip por ip.



  • Olha primeiro os logs do proxy.
    Se não marcou nenhuma autenticação no squid, não vai aparecer em nenhum relatório.



  • @marcelloc:

    Olha primeiro os logs do proxy.
    Se não marcou nenhuma autenticação no squid, não vai aparecer em nenhum relatório.

    De fato os logs estão somente com os ips. Sem usuários. Mas de fato no squid está sem autenticação mesmo. Tentei acertar isso, mas creio que eu esteja fazendo algo errado. Na aba "Authentication", no "Proxy Server", coloquei para fazer a autenticação pelo Freeradius, porém isso só foi possível se eu desmarcar a opção de proxy transparente. Desmarquei! Porém parou de gerar relatórios. Somente gera com o proxy transparente habilitado.



  • Só a autenticação _captive porta_l e wmi funcionam em modo transparete. Qualquer outra que marcar, vai ter que configurar o proxy nas estações



  • @marcelloc:

    Só a autenticação _captive porta_l e wmi funcionam em modo transparete. Qualquer outra que marcar, vai ter que configurar o proxy nas estações

    Hum!
    Aqui não posso configurar as estações, pois tratasse de uma faculdade. Daí não tem como eu configurar celular e notebook de cada aluno.
    Só que assim, consigo continuar utilizando o freeradius ou tenho que usar o captive portal para a autenticação? Pois modifiquei a autenticação no squid para captive portal, com o freeradius funcionando, e o squid parou.



  • @guinao_99:

    Pois modifiquei a autenticação no squid para captive portal, com o freeradius funcionando, e o squid parou.

    Já viu esse tópico?
    https://forum.pfsense.org/index.php?topic=66809.msg580982#msg580982



  • @marcelloc:

    @guinao_99:

    Pois modifiquei a autenticação no squid para captive portal, com o freeradius funcionando, e o squid parou.

    Já viu esse tópico?
    https://forum.pfsense.org/index.php?topic=66809.msg580982#msg580982

    Não tinha visto não. Poxa! Valeu mesmo. Vou ver se consigo acertar de acordo com esse post.



  • Olhei o tópico que você indicou, Marcelo.

    https://forum.pfsense.org/index.php?topic=66809.msg580982#msg580982

    Segui os passos que foram passados no tópico.

    O…

    tail -f /var/squid/logs/cache.log
    

    Gerou o seguinte resultado:

    2016-02-16 21:23:42 [44051] /usr/local/bin/squidGuard: can't write to logfile /var/log/squidGuard/squidGuard.log
    2016-02-16 21:23:42 [44051] New setting: logdir: /var/squidGuard/log
    2016-02-16 21:23:42 [44051] New setting: dbhome: /var/db/squidGuard
    2016-02-16 21:23:42 [44051] /usr/local/bin/squidGuard: ACL destination blk_BL_aggressive is not defined in configfile /usr/pbi/squidguard-i386/etc/squidGuard/squidGuard.conf
    2016-02-16 21:23:42 [44051] Going into emergency mode
    2016-02-16 21:23:42 [43523] /usr/local/bin/squidGuard: can't write to logfile /var/log/squidGuard/squidGuard.log
    2016-02-16 21:23:42 [43523] New setting: logdir: /var/squidGuard/log
    2016-02-16 21:23:42 [43523] New setting: dbhome: /var/db/squidGuard
    2016-02-16 21:23:42 [43523] /usr/local/bin/squidGuard: ACL destination blk_BL_aggressive is not defined in configfile /usr/pbi/squidguard-i386/etc/squidGuard/squidGuard.conf
    2016-02-16 21:23:42 [43523] Going into emergency mode
    

    Já o…

    ln -s /usr/local/bin/php /usr/pbi/squid-i386/local/bin/php
    ln -s /usr/local/lib/php /usr/pbi/squid-i386/local/lib/php
    ln -s /usr/local/etc/php.ini /usr/pbi/squid-i386/local/etc/php.ini
    ln -s /usr/local/lib/libsqlite3.so.0 /usr/pbi/squid-i386/local/lib/
    

    Gerou para todos

    File exists
    

    Então os

    rm /usr/pbi/squid-i386/bin/check_ip.php
    cp /usr/local/bin/check_ip.php /usr/pbi/squid-i386/bin/
    

    Foram aceitos.

    Mas o…

    ls -l /usr/pbi/squid-i386/bin/check_ip.php
    

    Ficou em vermelho gerando…

    -rwxr-xr-x  1 root  operator  2769 Feb 16 21:39 /usr/pbi/squid-i386/bin/check_ip.php
    

    Coloquei a autenticação no squid pelo Captive Portal, em modo transparente mesmo, e os serviços se mantiveram rodando. Porém quando tento logar um usuário ele não vai. Só aceita quando volto a autenticação pra "none". Aí passa na hora

    A integração não está funcionando e não sei o motivo.



  • @guinao_99:

    2016-02-16 21:23:42 [43523] /usr/local/bin/squidGuard: ACL destination blk_BL_aggressive is not defined in configfile /usr/pbi/squidguard-i386/etc/squidGuard/squidGuard.conf
    2016-02-16 21:23:42 [43523] Going into emergency mode

    Seu squidguard está reclamando da configuração que fez…



  • @marcelloc:

    @guinao_99:

    2016-02-16 21:23:42 [43523] /usr/local/bin/squidGuard: ACL destination blk_BL_aggressive is not defined in configfile /usr/pbi/squidguard-i386/etc/squidGuard/squidGuard.conf
    2016-02-16 21:23:42 [43523] Going into emergency mode

    Seu squidguard está reclamando da configuração que fez…

    Modifiquei a configuração no squidguard e a "reclamação" parou (acho). Mas o "-rwxr-xr-x  1 root  operator  2769 Feb 16 21:39 /usr/pbi/squid-i386/bin/check_ip.php" ainda está vermelho e a autenticação ainda está com problema.

    Mandei as imagens do squidguard pra ver se tem algo errado. Só acho estranho se ele for a causa do problema da autenticação. Não teria que ser no Squid?

    Olha! Aprendi muita coisa aqui, mas ainda tem coisa que sou leigo!!!  :-\ :-\











    ![Sem título.jpg](/public/imported_attachments/1/Sem título.jpg)
    ![Sem título.jpg_thumb](/public/imported_attachments/1/Sem título.jpg_thumb)



  • veja o cache.log durante o reload do squid. O tail -f vai mostrar só as ultimas linhas.

    execute um ps ax | grep -i squid para ver se os processos estão no ar ou se morreram



  • @marcelloc:

    veja o cache.log durante o reload do squid. O tail -f vai mostrar só as ultimas linhas.

    execute um ps ax | grep -i squid para ver se os processos estão no ar ou se morreram

    Desculpa a demora pra responder, mas a correria está grande ultimamente.

    Pois bem. Segue o resultado dos comandos. Como eu disse, tem coisa que ainda sou leigo, então não sei se está certo isso.

    ![Sem título 2.jpg](/public/imported_attachments/1/Sem título 2.jpg)
    ![Sem título 2.jpg_thumb](/public/imported_attachments/1/Sem título 2.jpg_thumb)