What is wrong with my hardware!?!?!?!



  • I had the fortune/misfortune of inheriting some server componentry from an uncle who passed. I am trying to continue his work but lack much of his expertise. One of the things he did was setup a full enterprise network off of pfsense. I have been struggling with the installation process. I can boot from usb and get into the web gui, and do whatever I want. Then I attempt to install to the hdd and it seems to work but it hangs. I have tried pressing "I" during the install, and I have also tried pressing 99 when I get to the options page. I have disabled ahcp and enabled it in the bios as other forum posts recommended.

    When I boot it asks me to push f1 to continue, after doing so, it often freezes. With different combinations it sometimes gets to the screen asking for single user, multi user ect. If I push enter, or let it time out, the result is the same. It freezes. on a whim I moved the hdd into my main pc and found that it booted just fine. Did not even need to reinstall.

    I moved it back to the server and it again froze during startup. Here is the question. If it was a hardware incompatibility, why would it work when booting from the usb? if it was a bad ISO, or a bad install, why would it work on personal machine? I have a working HDD with pfsense on it, and a machine that will run it off a flash drive, so what about booting from the hdd is different?

    Personal rig
    amd 8350
    gtx 660
    asrock extreme 4
    32 gb kingston ram
    120 gb kingston ssd

    server machine
    intel e2200
    2 gig of ram
    160 gig wd drive
    RS100-X5/PI2



  • Definitely sounds like a hardware/BIOS/config issue,  I found a previous post that may be helpful(?) :https://forum.pfsense.org/index.php?topic=96316.0

    Probably will take some combination of playing with the MB BIOS settings and choosing your install media (CD vs USB) to get it working right.

    I would suggest you move this to the Hardware forum for more useful info.

    But keep at it, the pain involved in solving these types of problems invariably translates into learning that will serve you well  ;)



  • Go grab a copy of memtest86 and test the RAM overnight and make sure it's good.
    Update the BIOS to the latest  (If need be), then reset it to defaults.

    Are you using the 32 or 64 bit version of pfSense?  (use 64bit)

    Also that system is pretty ancient.  Somewhere about 8 or 9 years old.  As much as I like keeping ancient crap, eventually it's gotta go (I swear I'll throw away that Dual P3 server, this year …. or maybe next year)



  • I have tried both the 32 and 64 bit versions. Neither worked. I will admit though I did almost all of my testing with the 64 bit and just tried out the 32 to see if it would work.

    I am currently running mem test and it made it through two passes so far with no issues. I will try updating the bios tomorrow morning and keep you posted.

    @SnowGhost Why would I throw out good hardware? It is easily over the specs to run my software and my current rent setup does not include me paying for electricity. But more than that it has sentimental value to me. I plan to upgrade it eventually, but I want to build on brents legacy. I dont want to just throw out what he did. When I get it running and feel a need, I will replace it.



  • A BIOS upgrade is a good place to start. If that alone doesn't help, try resetting the BIOS to defaults and try again. Sometimes something weird gets set for some particular usage that doesn't behave well for future uses.



  • Sorry to hear about your loss.

    A good place to start, as pointed out before, is a bios-reset to defaults.
    If this wont help, a good bios-update
    Try a fresh install of some OS, that you know will work on your HW smoothly.
    Given, that the used componentes (CPU/RAM/NIC/Disk/Graphics/PSU/BiosBattery etc.) are non faultive, this may lead you to a functioning system, also with pfsense - if the devices are supported with BSD.

    Kind regards
    Walbog



  • I have reset the bios to factory defaults, it has the most recent bios, and it was running fedora linux when I got it. There were two other machines like it and I was under the impression that at least one of them was running pfsense. I am not sure, but there was a good chance that they had the same hardware inside. I dont have access to the other machines, so I cant verify their operating systems, in addition I know that the most likely candidate for it had windows server installed after brents passing.

    I have searched the compatibility list on the bsd compatibility list and I did not find any real information on the motherboard in the documentation. I could have missed it though. If someone who knows more than me can double check it I would greatly appreciate it.

    Is there a way that I can just set a dedicated flash drive as the boot media and get it to save? I can get the initial setup but any restart removes any adjusted settings. If I could just dedicate the flashdrive to run the operating system I would be happy. Is there any feasibility to this method? I believe freenas can do something similar, and that is run off the bsd architecture.



  • It's a compatible machine in theory. What you see on occasion is hardware quirks that other OSes might not trigger, or might have workarounds for, where other OSes may not.

    You can run all the time from a USB flash drive, just choose the nanobsd version, and write that out to the USB flash drive. Boot and run from that.