Installation Fails: OpenVPN Client Export Package



  • I tried last Sunday and again today. The installation fails with a bad archive as shown below.

    I downloaded the .pbi to my Windows computer and tried to open it with 7zip. 7zip also fails to extract and reports: "There are some data after the end of the payload data: zip-3.0_1-amd64"

    Beginning package installation for OpenVPN Client Export Utility .
    Downloading package configuration file… done.
    Saving updated package information... done.
    Downloading OpenVPN Client Export Utility and its dependencies...
    Checking for package installation...
    Downloading https://files.pfsense.org/packages/10/All/zip-3.0_1-amd64.pbi ...  (extracting)
    Verifying Checksum...SKIP_ARCHLINES: 61
    Archive checksum: cf97803d2012616f54f3338e8d7b04acdce6aa96592e0c89ecc946bc4da93d33
    Saved checksum: f2677788ffece6045019c6460481718940c07381031f982819c98f1f985a78f1
    ERROR: /tmp/apkg_zip-3.0_1-amd64.pbi failed checksum, the archive may be corrupt.
    of zip-3.0_1-amd64.pbi p7zip-9.20.1_2-amd64 failed!

    Installation aborted.Removing package...
    Starting package deletion for zip-3.0_1-amd64...done.
    Starting package deletion for p7zip-9.20.1_2-amd64...done.
    Removing OpenVPN Client Export Utility components...
    Tabs items... done.
    Loading package instructions...
    Include file openvpn-client-export.inc could not be found for inclusion.
    Deinstall commands...
    Not executing custom deinstall hook because an include is missing.
    Removing package instructions...done.
    Auxiliary files... done.
    Package XML... done.
    Configuration... done.
    done.
    Failed to install package.

    Installation halted.


  • LAYER 8 Global Moderator

    not sure where your getting the checksum from??

    if you look in the .sha256 file shows
    17d974f384c5d903a67744bd6e4bf7cbc80260acb6eec717b6c29f9daf40c86e

    What version of pfsense are you running??

    I show this working just fine

    Removing OpenVPN Client Export Utility components…
    Tabs items... done.
    Loading package instructions...
    Deinstall commands... done.
    Removing package instructions...done.
    Auxiliary files... done.
    Package XML... done.
    Configuration... done.
    Beginning package installation for OpenVPN Client Export Utility .
    Downloading package configuration file... done.
    Saving updated package information... done.
    Downloading OpenVPN Client Export Utility and its dependencies...
    Checking for package installation...
    Downloading https://files.pfsense.org/packages/10/All/zip-3.0_1-amd64.pbi ...  (extracting)

    Downloading https://files.pfsense.org/packages/10/All/p7zip-9.20.1_2-amd64.pbi ...  (extracting)
    Loading package configuration... done.
    Configuring package components...
    Loading package configuration... done.
    Additional files... done.
    Loading package instructions...
    Custom commands...
    Executing custom_php_install_command()...done.
    Integrated Tab items... done.
    Writing configuration... done.

    Package reinstalled.



  • From the dashboard:

    2.2.6-RELEASE (amd64)
    built on Mon Dec 21 14:50:08 CST 2015
    FreeBSD 10.1-RELEASE-p25

    You are on the latest version.

    I am not "getting the checksum" from anywhere. I simply:
    1.  Go to https://{local LAN IP address}/pkg_mgr.php
    2.  Click on the install button for OpenVPN Client Export Utility on that page
    3.  Which takes me to https://{local LAN IP address}/pkg_mgr_install.php?id=OpenVPN%20Client%20Export%20Utility
    4.  I click on Confirm
    5.  Which takes me to https://{local LAN IP address}/pkg_mgr_install.php
    6.  Where the installation fails again, although with a new failure mode:

    Beginning package installation for OpenVPN Client Export Utility .
    Downloading package configuration file… done.
    Saving updated package information... done.
    Downloading OpenVPN Client Export Utility and its dependencies...
    Checking for package installation...
    Downloading https://files.pfsense.org/packages/10/All/zip-3.0_1-amd64.pbi ...  (extracting)
    ERROR: Failed to read PBI header! Possible corrupt PBI, or wrong PBI version for this OS.
    of zip-3.0_1-amd64.pbi p7zip-9.20.1_2-amd64 failed!

    Installation aborted.Removing package...
    Starting package deletion for zip-3.0_1-amd64...done.
    Starting package deletion for p7zip-9.20.1_2-amd64...done.
    Removing OpenVPN Client Export Utility components...
    Tabs items... done.
    Loading package instructions...
    Include file openvpn-client-export.inc could not be found for inclusion.
    Deinstall commands...
    Not executing custom deinstall hook because an include is missing.
    Removing package instructions...done.
    Auxiliary files... done.
    Package XML... done.
    Configuration... done.
    done.
    Failed to install package.

    Installation halted.

    Perhaps a conflict with pfSense 2.2.6?


  • LAYER 8 Global Moderator

    I am on 2.2.6 have been since it came out..

    My guess would be your downloads are corrupt… Why don't you manually download the package and validate its checksum..



  • Johnpoz, thank you so much for your help. I solved my problem.

    A little backstory in mitigation: I have been futzing with converting a VMware VM to Hyper-V and I have created this VM about a dozen times over about 6 weeks of part-time effort punctuated by hospital stays.

    The problem was that instance I was working on was a LiveCD image, not a disk image. Works a whole lot better if you use a write-enabled storage medium.


Log in to reply