Internet connectivity issue in one part of network



  • To fully understand the following, please see attached (partial) diagram of my network.

    I have a home network where pfSense performs routing in addition to being a firewall. I use static addressing across the network. Everything I normally use on the network works just fine. However, I've had some slow internet issues lately and wanted to jack into the modem directly with a laptop to test and I had no internet at all with DHCP set on the laptop (modem uses DHCP between itself and pfSense because I can't access the settings on it). I tried another laptop with the same result.

    I tried connecting everything back to normal and connecting the laptops to the switch. Still no internet. They do have network connectivity though and I can ping pfSense but not other devices. I cannot ping 8.8.8.8 and other public IPs. If I switch the laptops to wireless, everything works just fine. I cannot access the modem's login either from this point but can everywhere else in the network. I can also access the internet and everything just fine from the IDS in the diagram. Is there some setting in pfSense that is screwing with this? I use the same addressing and default gateway (192.168.1.1) as everything else but for some reason it just doesn't work. I even replaced the switch with a brand new one I had lying around and had the same result. Please help. I need to figure out what this is before I can try to get my ISP to determine what the speed issue is.
    ![home network.png](/public/imported_attachments/1/home network.png)
    ![home network.png_thumb](/public/imported_attachments/1/home network.png_thumb)