WAN dropping connection



  • Hi folks,

    I'm not really sure if this is the right section, but here's my problem.

    My WAN drops. Status is connected, no strange things in the logs, no weird firewall rules, I disabled gateway monitoring, changed WAN to another interface. I can connect to any device on the LAN, but i cant ping Google DNS.

    My WAN is connected to the cable modem (not bridged, but the pfsense box is in a dmz for now) via a managed switch (isolated the 2 switch ports) and my LAN is in a separate vlan. Another vlan bypasses the pfsense box and talks to the cable modem directly (never any internet connection lost there) I know double NAT is not best practice, but i cant have the rest of the house losing internet connectivity.

    My system is a Supermicro A1SRi-2558F
    I'm on the latest stable pfSense version

    Any help would be greatly appreciated. Let me know if you need more info.

    I also unchecked the "Block private networks" option in the WAN interface.
    I also tried checking the "Disable hardware checksum offload" option.
    I switched ports on the modem as wel as on the pfSense machine
    I switched cables
    I also tried with the modem directly connected to the WAN (so without the switch in between)



  • Anyone? Do i need to provide more info?



  • Not sure if this is your problem or not but it might be worth checking into.

    https://forum.pfsense.org/index.php?topic=101519.msg0#new



  • What happens if you connect your WAN from your pfSense box direct to your Modem ?
    These drops are random or after a certain period of time?
    You can try is set the speed settings of your WAN and Switch port with fixed speed.
    Problems with auto-negoitiation between your WAN and Switch can cause these WAN drops also.

    Grtz
    DeLorean



  • I've taken the risk of the lady of the house leaving me and my children no longer recognizing me a a father… aka risk losing internet connection in the house... I had my ISP put the modem in bridge modus.

    The fact that i am able to respond here means I survived and that that indeed solved the problem!  8)

    I am still a bit confused here, since i couldn't find anything in any log. Probably an issue with the modem in that area(?). Which is still akward, since i had other WiFi routers behind it doing NAT before and never had any issues with those. Sigh... Network troubleshooting is hard sometimes. Does make me respect the "IT Guys" from the office more  :P



  • Nice to hear that your lady and kids still recognize you as a father  ;D



  • Haha yes. I think i dodged a bullet here :o


Log in to reply