Connection problems



  • Since more than a week I'm having heavy connection problems.
    I have a 120/12mbit connection and normally I get the full speed (more or less).
    But the last week my connection dropped to 50mbit down and 6 or 7 up.
    Also I'm having major packetloss if I check the gateway in pfSense, sometimes 30 - 50% packetloss.

    Checking the gateway logs gives me the following:

    apinger: alarm canceled: WAN_DHCP(Gateway IP) *** loss ***
    apinger: alarm canceled: WAN_DHCP(Gateway IP) *** down ***
    apinger: ALARM: WAN_DHCP(Gateway IP) *** down ***
    apinger: ALARM: WAN_DHCP(Gateway IP) *** loss ***
    

    These messages are repeated on a regular basis.

    Checking the general logs gives me the following:

    php-fpm[57659]: /rc.openvpn: OpenVPN: One or more OpenVPN tunnel endpoints may have changed its IP. Reloading endpoints that may use WAN_DHCP.
    php-fpm[52608]: /rc.dyndns.update: phpDynDNS (home): No change in my IP address and/or 25 days has not passed. Not updating dynamic DNS entry.
    check_reload_status: Reloading filter
    check_reload_status: Restarting OpenVPN tunnels/interfaces
    check_reload_status: Restarting ipsec tunnels
    check_reload_status: updating dyndns WAN_DHCP
    

    These messages are repeated pretty often as well.

    I have phoned my ISP (Ziggo) and they are checking the connection to my home.
    But they told me the problem would most likely be my router/firewall, the pfSense box (APU1D4).

    Do you guys think the problems are caused by the pfSense box or my internet connection itself?



  • could be apinger or could be your modem. have you tried restarting/rebooting both ?



  • Yes, I have tried both (reboot pfSense box and modem).
    If I "reset" the modem, pull power plug and leave it for 30 seconds before powering it back on I get full speed again.
    This could be for a few hours (sometimes days) but than falls back again.



  • Ok, I have power cycled my modem this morning around 8.30 AM (CET).
    I got full speed again and no packetloss. Since 1pm (CET) the connection is breaking up again.
    Just checked and had 14% packetloss (at the gateway monitoring).
    Speeds dropped back to 60/7 mbit also.



  • try pinging the gateway monitor ip (or other public ip's) from console. see if you can detect packetloss that way.

    If everything seems ok from console, then disable gateway monitoring & see if this solves it.



  • Thanks for your help. heper.
    I just got a phone call from my ISP, the problem is within their network and trying to fix this asap.


Log in to reply