DHCPv6 Server/RA problem



  • Hi all,

    I'm getting this message when I go to that config screen:

    The DHCPv6 Server can only be enabled on interfaces configured with a static IPv6 address. This system has none.

    My LAN sure seems to have an IPv6 address.  The LAN is set to "Track Interface" off the WAN.  Status - Interfaces shows the LAN has an IPv6 address.

    For what it's worth, I can ping ipv6.google.com from the router Diagnostics - Ping menu.

    pfsense version 2.2.6-RELEASE  ISP is Time Warner.

    Any suggestions please?

    thanks,
    Dave



  • A LAN interface that is setup for Track Interface operation actually runs a "hidden", non-configurable DHCP6 server which will assign addresses in the range prefix::1000 through prefix::2000.



  • @awebster:

    A LAN interface that is setup for Track Interface operation actually runs a "hidden", non-configurable DHCP6 server which will assign addresses in the range prefix::1000 through prefix::2000.

    Ok, I had just a minute ago discovered that the "Track Interface" choice is what resulted in my inability to access the menu I wanted.

    So, according to your statement, I already have a DHCPv6 server running and available to my LAN?

    Thanks for your reply by the way.



  • Track Interface does the following…

    • Sets RA type to Assisted
    • Enables DHCPv6 with an address range of ::1000 to ::2000

    The assisted RA type means that a device will use SLAAC if it is able to use it. Nearly all IPv6 devices use SLAAC, but some may not be able to, or might be configured to specifically use DHCPv6. For devices that only support DHCPv6 or are configured to only use DHCPv6, they will get an address from the DHCPv6 server within the address range.

    It has been said that in pfSense 2.3, interfaces that use the Track Interface setting will be allowed to customize RA and DHCPv6 settings. That capability is not yet present in the beta version, though. There is no doubt that there are some tricky circumstances surrounding the ability to allow that, especially with a prefix that can change at a moment's notice from your ISP.


Log in to reply