Pfsense Setup with Layer 3 Managed Switch–HELP



  • Hi there,
    Working on replacing a L2 Cisco SG200-26 on my network with a Dlink DGS-1510 L3 switch and I am breaking my head as I cannot make this work…I have read the posting, but I am at a loss as I cannot configure this replacement.

    Here's my simplified setup ( detailed diagram attached):
                                                                              |---->DHCP VLAN 10 WS12R2 ( 2 SCPES in VLAN 10 & 33)
                                                                              |        10.0.0.11 
                                                                              |         
    WAN------->PFSENSE--------->Cisco SG200-26----->----->NAS VLAN10 IP 10.0.0.5
                      10.0.0.1              10.0.0.2                |
                      2 VLANS 10&33                                  |
                                                                              |---->TS8-POE SWITCH----->UBIQUITi WIRELESS on 10.0.0.0/24 SUBNET
                                                                              |            10.0.0.10
                                                                              |
                                                                              |----->VLAN33 providing client services to VLAN 33 (10.0.33.xx)

    Here's what I've done so far, I read the postings and

    1. SET STATIC IP for PFSENSE at 10.0.0.1
    2. SET STATIC IP for L3 SWITCH at 10.0.0.3
    3. removed the VLANS from PFSENSE so right now the L3 Switch is doing all the VLAN connection so:

    WAN----> PFSENSE------>LACP to SWITCH---->VLAN10
                                                                        >VLAN33
    4) SET under L2 settings in the L3 switch 2 VLANS ( 10 & 33 with IP address 10.0.0.1/24 & 10.0.33.1/24)
    5) SET TRUNK port between PFSENSE and L3 Switch
    6) SET IPv4 interfaces on L3 switch for both VLANS
    7) SET Static ROUTE on L3 SWITCH pointing to PFSENSE gateway 10.0.0.1
    8) SET and ENABLE DHCP relay so clients in L3 switch will get an address from DHCP server ( This is not working)

    I read that I have to set static routes on PFSENSE to point to the L3 switch but Ive seen contradicting postings on this plus I am not sure how to do that exaclty

    At this point this setup does not work, I cant even get the VLANS to talk to each other, so I am reaching out to find out where I am going wrong...

    Thanks for the help

    ![Screen Shot 2016-02-14 at 4.36.24 PM.png](/public/imported_attachments/1/Screen Shot 2016-02-14 at 4.36.24 PM.png)
    ![Screen Shot 2016-02-14 at 4.36.24 PM.png_thumb](/public/imported_attachments/1/Screen Shot 2016-02-14 at 4.36.24 PM.png_thumb)


Log in to reply