FIREWALL BLOQUEANDO FTP



  • Pessoal, boa tarde

    Após atualizar o pfsense para a versão 2.2.4 estou com problemas em dois cliente com FTP..
    O problema nos dois clientes é o seguinte, o cliente tem um sistema que gera um relatório em um determinado diretório e é preciso enviar para um destino FTP.
    Já liberei o ip deste micro onde fica o sistema, está tudo liberado e nao vai.
    Em um dos clientes voltei para a versão 2.1.5 e está ok, este outro cliente que estou, gostaria de descobrir o problema..
    Alguém com o mesmo problema com essa versão?



  • Instale o pacote FTP Proxy Client, depois habilite e selecione a interface LAN, deixe os outros parâmetros como estão e salve.



  • Tomas, obrigado..

    Havia pego um tópico que o Marcelloc fala algo parecido..

    https://forum.pfsense.org/index.php?topic=7174.0 (Problemas ao conectar servidor FTP)

    Já fiz, agora para testar só mais tarde, agradeço.

    Posto o resultado mais tarde, vlw



  • Não funcionou



  • @WTF_Cléio:

    Não funcionou

    Não funcionou a minha dica ou a do post no forum?



  • Fiz a sua dica e a do post tamb´m e nada..  :-\



  • confere sua regra que libera a porta 21 e veja se o serviço FTP Proxy Client está rodando, pois onde tive problemas sempre resolveu.



  • Olá,
    Eu estou na mesma situação do Cléio.Sousa, não consigo fazer funcionar.
    Instalei o FTP Proxy Client, criei as regras conforme o tutorial do Marcelo e não consigo acesso ao ftps externos.
    O Cliente ftp como por exemplo FilleZilla e WinSCP, é autenticado no Servidor Ftp, mas, não lista as pastas.

    Grato.



  • como disse, tenho esse cenário em clientes e funciona normal.
    Como esta a regra que libera a porta 21 e qual interface selecionou no FTP Proxy client?



  • Olá Tomas,

    1 - FTP Proxy Client: habilitado interface LAN
    2 - Regras na LAN: TCP LAN net * IpsFTP 21 (FTP)         *   Acesso a servidores FTP autorizados 
    3 - Regra na WAN:  TCP IpsFTP 20 WAN net  * *   Acesso a servidores FTP externos (modo ativo)

    At.



  • @Márcio:

    Olá Tomas,

    1 - FTP Proxy Client: habilitado interface LAN
    2 - Regras na LAN: TCP LAN net * IpsFTP 21 (FTP)         *   Acesso a servidores FTP autorizados 
    3 - Regra na WAN:  TCP IpsFTP 20 WAN net  * *   Acesso a servidores FTP externos (modo ativo)

    At.

    Desligue a regra da porta 20 para testar.



  • Tomas,
    Obrigado pela ajuda, mas, nada esta dando certo. Estou muito preocupado, porque não consigo acessar nenhum ftp.

    Grato.



  • Algum detalhe passando desapercebido, só vendo o ambiente para te dizer.



  • TOMAS, consegui validar no meu cliente, e deu certo, vlw



  • Você usa proxy na máquina ? Se não basta liberar tudo que vem dessa máquina. Se sim faça como disse o Tomas, instale o FTP Client Proxy marque enable FTP proxy, escolha a interface do proxy, e marque a caixa Early Firewall Rule e salve pois assim irá funcionar.
    Explicação: Mesmo estando tudo liberado para as portas de destino 21 e 20 ( padrão FTP ativo e passivo ) e usando o proxy na máquina o mesmo intercepta a conexão por isso não conecta e com o FTP, e isso só ocorre em servidores que usam as portas padrão.