install problem "run_interrupt_driven_hooks waiting for xpt_config" (SOLVED)



  • Hello friends,

    I have this error "run_interrupt_driven_hooks waiting for xpt_config" when trying to install pfsense server. I tried several things and even the error persists. I'll give you the information and what I have done:

    Server: HP ProLiant ML350 G5
    Version 2.2.6 PFsense

    I'm trying to install the pfense for the first time, so it is a clean installation. Download the file for 64-bit architectures to boot from a USB, then start the installation in the process give me the error "run_interrupt_driven_hooks waiting for xpt_config".

    Reading several posts and recommendations, in addition to the troubleshooting section of pfsense almost all recommend disabling Firewire port (1394), disable usb, floppy, serial, etc. I did everything even disable iLO port, with exception of the Firewire because the server does not have that port, this force myself to get off the pfsense architecture 64bit again but to be installed with livecd, the server starts the installation and at the same point i get the same error.

    all entries that have found point to the same route.

    I hope you can help me.



  • Maybe you tried this too:
    https://forum.pfsense.org/index.php?topic=48478.0 resp.
    here http://doc.pfsense.org/index.php/Boot_Troubleshooting#Conflicting_Hardware

    If using a CD, try disabling USB if possible (except, if you are using a USB-CD-Drive of course). Might there be a flash-drive or such in your DL somwhere?

    Regards



  • @walbog:

    Maybe you tried this too:
    https://forum.pfsense.org/index.php?topic=48478.0 resp.
    here http://doc.pfsense.org/index.php/Boot_Troubleshooting#Conflicting_Hardware

    If using a CD, try disabling USB if possible (except, if you are using a USB-CD-Drive of course). Might there be a flash-drive or such in your DL somwhere?

    Regards

    Thanks for your reply,

    I already tested disabling all USB ports and use a CD installer, but didn't work and i'm a bit desperate with this issue!!!



  • I already tested disabling all USB ports and use a CD installer, but didn't work and i'm a bit desperate with this issue!!!

    Like many others but since the USB installation will work flawless smooth and liquid there is often no really
    need to use a CD/DVD device anymore. So you could get a USB pen drive and then push there on the amd64
    version of pfSense there are pre-defined USB pen drive images to do so and then install from there.

    Server: HP ProLiant ML350 G5
    Version 2.2.6 PFsense

    It could be that there are some quirks with the BIOS or some BIOS settings with this device.
    How many RAM and what CPU is in that device? How many and what kind of LAN Ports (NICs)
    are inside of this server?



  • Hello BlueKobold,

    I just solved my problem and I finally install pfSense, thank you for your interest.

    Like many others but since the USB installation will work flawless smooth and liquid there is often no really
    need to use a CD/DVD device anymore. So you could get a USB pen drive and then push there on the amd64
    version of pfSense there are pre-defined USB pen drive images to do so and then install from there.

    I agree with you with respect to the USB ports but i disable by recommendations in the Boot Troubleshooting (hardware conflict).

    It could be that there are some quirks with the BIOS or some BIOS settings with this device.
    How many RAM and what CPU is in that device? How many and what kind of LAN Ports (NICs)
    are inside of this server?

    My server has 5 GB of RAM and an Intel Xeon CPU 3.20GHz processor by default brings only 1 network port but bought a Hp Nc360t Dual Port Pci-e X4 Gigabit Server Adapter 412651-0 (with 2 networks ports) to have a total of 3 network ports.

    Here are the settings that work for me:

    • USB ports disabled.

    • Serial port disabled.

    • Parallel port disabled.

    • Integrated lights-out disabled. (Also called port ILO).

    • Floppy disabled.

    • Integrated SCSI ports disable (u320 HBA Port1 and u320 HBA Port2).

    I use the latest version of pfsense 2.2.6 64-bit architecture.

    NOTE: The integrated SCSI ports they are not using because it had all the hard drives are connected to the PCI RAID controller.

    I hope will be helpful to many here in the community. ;)