Wan interface won't recieve ip address from ISP Comcast



  • Hi guys. I would not post the question as this is step one but no matter what i do i can't get wan ip address assigned from isp to pfsense installed on vm box. I did check wan int is my physical nic card from my desktop that matches virtual mac in oracle vm box setup. If i spoof mac in wan i can get on internet then but then dns won't resolve external host like my vpn host name so i can setup and activate vpn.

    I have no issue with my router, my pc nic card but not with pfsense.

    My setup is as follows 2 physical nic card in desktop windows 7 running oracle vm box, installed pfsense, I also want to integrate my router as AP for wifi. So i run modem cable to my desktop integrated nic1 then nic2 cable to AP in AP mode.
    I leave my ap as .1 and set gateway as my .2 which is my pfsense web interface number. I reserve .1 as static in dhcp reservation in pfsense for AP. Exclude .1 as dhcp range. Sometimes i can't connect to pfsense web interface too.

    Nics are correcly assigned. Problem is my console won't show wan ip..it's blank..

    I'm trying to setup open vpn client on it and do other stuff later. I've tried for 3 days and i'm out of ideas so i'm asking for help here. Is it possible that comcast is blocking pfsense somehow?



  • I have heard of similar issues when users have a Cable modem only (not a business gateway.  the root cause ended up being that Cable Modems seems to bind themselves to the first Layer 2 device that connects to them on boot up.  Depending on how you configured the VM network that could be a Switch or another device and not the NIC card that you need it to be associated with.


Log in to reply