[Resolve] Wrong wan ip with pfsense

  • Hey, I have some problem with PFsense2.2.6,
    my current setup is

    Internet modem –>DD-WRT router--> LAN (switch)

    I have replaced DD-WRT with Sophos UTM and everything is working fine (but with a twist) my Sophos is inside VMware ESXI with a USB to eth passtrough, so my current setup is
    Internet Modem --> USB to eth = nic1 (inside esxi pastry Sophos) --Nic2--> LAN

    And it's working, but the home version of Sophos doesn't let you do packet shaping, and the cool option one might need are locked. So I want to give PFsense a try, but... here is my problem. I can install PFsense without a problem, he can see both of my nic, and i can go into to administer it.

    both DD-WRT and sophos get the good WAN ip address from my internet provider (videotron , im in quebec so sorry for my bad english)
    wich is  173.178.XX.XXX (in DHCP)
    but with Pfsense im getting
    with the error in log

    apinger: Could not bind socket on address( for monitoring address with error Can't assign requested address 

    Hope you guys can help me ! :D

  • is also a good Videotron address.  Cable?  Generally when the MAC address changes on the customer side of a cable modem (bridge) then you will get handed a different IP address. Its normal.

    The error in the log I don't know however.

    Can you try spoofing the MAC address of your DD-WRT router onto the WAN of your pfSense box?

  • Thanks for the hand !

    i already done that, and the ip adress become the same as dd-wrt, but no internet access

    apinger: Could not bind socket on address(173.178.30.xxx) for monitoring address with error Can't assign requested address

    strange thing, i can ping but i cannot ping google.ca

  • Looks like you have no DNS.  Have you entered them manually?

  • I want to thanks Sbingner, on irc for helping me a LOT !!!, the problem was … that my usb card was ''crashing'' he found out that the usb card was sending packet but not receiveing them, because of bad checksum
    the answer to my problem was to tick and voila !

    Disable hardware checksum offload
    Checking this option will disable hardware checksum offloading. Checksum offloading is broken in some hardware, particularly some Realtek cards. Rarely, drivers may have problems with checksum offloading and some specific NICs.
    Note:  This will take effect after you reboot the machine or re-configure each interface.

    also that you chpalmer for the time you spend answering me on the forum !

  • Glad you got it working!  :)

Log in to reply