Pfsense 2.1 och Alix 2d3 with ZTE MF831 stuck in reboot loop



  • Hello everybody,

    We currently have 7 of these units. However, after a few reboots or some time (we don't know yet) something happens with the modem and pfsense can no longer start up.

    The modem is working perfectly when connected to a windows computer and if we replace the modem on the unit it starts up for some time.

    Now we have 4 units down because of the same issue. As soon as I'm at the office I can send information about what the terminal is saying when booting up but if anyone of you have any idea of what is wrong, help would be much appreciated.

    / Johan



  • Small update on the subject.

    It appears that the modems built in CD device stopped working for some reason.
    I can't mount the cd in windows any longer.



  • Try to disable CD.



  • My first impression that the CD didn't mount was wrong. It mounts in Windows but it takes some time.

    It's weird. The modem worked and then stopped working in pfsense. If I replace the modem with another one it works for a few restarts and then it stops working.

    I'm going to try to disable CD. I'm currently investigating how to do that with AT-commands. I tried telnet but it doesn't work, ssh doesn't work either.

    I plugged it into a Ubuntu live PC and I can see the device as ttyUSB0 but all commands i try fail.

    I use putty like this: putty /dev/ttyUSB0 but it fails.