Client OpenVPN não conecta apos informar usuario e senha (AUTH_FAILED)



  • Boa noite.
    Ao tentar conectar via openvpn gui e informar o usuario e senha e seguinte log é exibido, logo em seguida solicita autenticação novamente.

    Ja conferi usuario e senha esta ok, ja alterei, ja reconfigurei a vpn e nada ainda

    Sat Feb 27 19:51:09 2016 DEPRECATED OPTION: –tls-remote, please update your configuration
    Sat Feb 27 19:51:09 2016 OpenVPN 2.3.2 i686-w64-mingw32 [SSL (OpenSSL)] [LZO] [PKCS11] [eurephia] [IPv6] built on Jun  3 2013
    Sat Feb 27 19:51:15 2016 Control Channel Authentication: using 'fyrewall-udp-1194-atoniate-tls.key' as a OpenVPN static key file
    Sat Feb 27 19:51:15 2016 UDPv4 link local (bound): [undef]
    Sat Feb 27 19:51:15 2016 UDPv4 link remote: [AF_INET]XXX.XXX.XXX.XXX:1194
    Sat Feb 27 19:51:15 2016 WARNING: this configuration may cache passwords in memory – use the auth-nocache option to prevent this
    Sat Feb 27 19:51:16 2016 [MyServerCert] Peer Connection Initiated with [AF_INET]XXX.XXX.XXX.XXX:1194
    Sat Feb 27 19:51:18 2016 AUTH: Received control message: AUTH_FAILED
    Sat Feb 27 19:51:18 2016 SIGUSR1[soft,auth-failure] received, process restarting

    Alguem ja teve este problema e encontrou alguma solucao?



  • @andretoniate:

    Boa noite.
    Ao tentar conectar via openvpn gui e informar o usuario e senha e seguinte log é exibido, logo em seguida solicita autenticação novamente.

    Ja conferi usuario e senha esta ok, ja alterei, ja reconfigurei a vpn e nada ainda

    Sat Feb 27 19:51:09 2016 DEPRECATED OPTION: –tls-remote, please update your configuration
    Sat Feb 27 19:51:09 2016 OpenVPN 2.3.2 i686-w64-mingw32 [SSL (OpenSSL)] [LZO] [PKCS11] [eurephia] [IPv6] built on Jun  3 2013
    Sat Feb 27 19:51:15 2016 Control Channel Authentication: using 'fyrewall-udp-1194-atoniate-tls.key' as a OpenVPN static key file
    Sat Feb 27 19:51:15 2016 UDPv4 link local (bound): [undef]
    Sat Feb 27 19:51:15 2016 UDPv4 link remote: [AF_INET]XXX.XXX.XXX.XXX:1194
    Sat Feb 27 19:51:15 2016 WARNING: this configuration may cache passwords in memory – use the auth-nocache option to prevent this
    Sat Feb 27 19:51:16 2016 [MyServerCert] Peer Connection Initiated with [AF_INET]XXX.XXX.XXX.XXX:1194
    Sat Feb 27 19:51:18 2016 AUTH: Received control message: AUTH_FAILED
    Sat Feb 27 19:51:18 2016 SIGUSR1[soft,auth-failure] received, process restarting

    Alguem ja teve este problema e encontrou alguma solucao?

    Como está sendo a conexão com esse usuário? ele está na base do pfsense ou ldap?

    abraços

    diego



  • Bom dia.

    Na base do pfSense mesmo.



  • @andretoniate:

    Bom dia.

    Na base do pfSense mesmo.

    qual o tipo de vpn?

    veja se esse tutorial te ajuda.. é para autenticar no Windows server 2008, mas o procedimento de configuração é "parecido".

    abraços,

    diego



  • @didonsom:

    qual o tipo de vpn?

    OpenVPN (Site to client)



  • Já reinstalei diversas vezes e nada ainda.



  • Criou o certificado de usuário corretamente?



  • @jotaherre:

    Criou o certificado de usuário corretamente?

    Creio que sim, até por que segui diversos videos na internet olhando detalhe por detalhe.

    Configurei com base no antigo pfsense com vpn usado na minha rede.

    Se tiver algum procedimento para indicar posso ver tambem, alem dos diversos que ja vi.

    Obrigado.



  • Seus usuarios estão com o certificado