DNS resolves wrong



  • Hey guys,

    Here is my story.
    There are two devices on my network: pfsenseFirewall with DNS Resolver, raspberryPi as a client and a windows client.
    Wrongly the raspberryPi got two IP addresses (10.0.0.2 static and 10.0.0.100 dhcp). I didn't want it to have two addresses, so I removed the address 10.0.0.100. This worked fine and also after a reboot, the raspberryPi just has one address: 10.0.0.2.
    Now if I resolve the raspberryPi's IP address from the windows client via nslookup I always get the old one 10.0.0.100, but I want to get the new one 10.0.0.2.
    Where does pfsense save this information?
    I already restarted the whole pfsense system.

    Does anyone has an idea or a hint?

    Greetz
    Michael


  • Rebel Alliance Global Moderator

    if you have pfsense putting dhcp leases into name resolution…  Just because you removed the dhcp address from the pi, does not mean the lease is still not there.

    Clear out the old lease in pfsense dhcp server.



  • Thank you, johnpoz.

    After deleting the entry in Status -> DHCP leases, the wrong IP doesn't come up again when doing nslookup.


  • Rebel Alliance Global Moderator

    More than welcome ;)  Glad I could be of help!