Embedded wont boot with 1.3 alpha alpha



  • i copied the image to the 1gb flash card and inserted into the alix2c3 and what i see is alix saying boot disk not found, it doesnt boot from the 1gb flash crad, tried multiple times but the same so currently trying 1.2.1, lets see what happens



  • 1.3 embedded will likely end up significantly different from what is there now. One of our developers is working on a complete rewrite of how embedded is built. In the mean time, 1.3 embedded is not likely to get much attention, though Scott did say he successfully tested it.



  • Sorry, cannot duplicate here.  Just installed gzcat Desktop/pfSense-20080707-1640.img.gz | dd of=/dev/disk1 bs=16k
    14818+1 records in
    14818+1 records out
    242786304 bytes transferred in 471.753433 secs (514647 bytes/sec)

    And it boots:

    Network interface mismatch – Running interface assignment option.

    Valid interfaces are:

    rl0    00:04:a7:08:86:22
    rl1    00:04:a7:08:86:21
    rl2    00:04:a7:08:86:20
    rl3    00:04:a7:08:86:1f
    et0    00:04:a7:05:da:0a
    et1    00:04:a7:05:da:0b

    Do you want to set up VLANs first?
    If you are not going to use VLANs, or only for optional interfaces, you should
    say no here and use the webConfigurator to configure VLANs later, if required.

    Do you want to set up VLANs now [y|n]?



  • I have the same issue with a WRAP board and V1.3 alpha (pfSense-Embedded-Update-1.3-ALPHA-ALPHA-20080707-2103.tgz), but used the Windows physdiskwrite (from http://m0n0.ch/wall/physdiskwrite.php)

    physdiskwrite xxxxxx.img  …. and I get the same issue.... which is basically....

    01F0 Master 848A SanDisk SDCFB-128
    Phys C/H/S 980/8/32 Log C/H/S 980/8/32
    No boot device available, press Enter to continue

    I'm willing to wait until the new embedded build is out, but figured I'd share as well.



  • The new images are for 256MB or larger cards.. Is your card this large?



  • i tried and its the same for 1.2.1



  • I'm using a 128mb card (I wasn't using a 256mb card, but I could) and didn't give a write error … it went to completion.  And it works perfectly with pfSense-1.2.img.gz, but doesn't work with the latest snapshot of pfSense-1.2.1 (pfSense-Embedded-Update-1.2.1-TESTING-SNAPSHOT-20080708-0032.tgz) either.  Maybe something got broken between 1.2 and 1.2.1.



  • i havent been around from some time now so just wanted to check if version 1.3 was ready to work in stable condition, both the embedded version as well as the full version.

    any1 running the latest embedded snapshot on a alix2c3?



  • It's ALPHA ALPHA, so no, it's not stable. But you can test it and post to the problem/feedback forum. I have played with the embedded images on my Alix 2c3. I have had no trouble getting it running, there are a lot of nice things going into 1.3.



  • Make sure you're writing the img.gz file, not the update tgz file. The update file is not a bootable image, it won't boot.



  • so basically i need to downlaod the img file and not the embedded update or the full update right?
    my next question is, suppose i have installed the img file and it works but daily snapshots that r generated, can it be upgrade to them directly from the web GUI or is it that i have to everytime remove the old and reinstall the new snapshot bcoz in alix2c3, i everytime i have to unplug everything, remove the lid, unscrew the board, remove the the CF card, insert into card reader and reflash and again re construct the whole thing and it gets a bit boring and time consuming.



  • Upgrades probably won't work on embedded, you have to reflash. I don't recommend using 1.3 embedded at this point, it's not going to use the same kind of setup it does now in the release version.


Log in to reply