Unifi AP and PFSense Failures



  • I have a pfsense router with a unifi ap on a separate vlan.  Took me hours to get it working 3 days ago, and I have no idea what I even did to get it working.  I accidentally factory reset when I was sshed into the AP, because I was frustrated by the fact that even though I was connected to the AP and getting internet, oddly the Unifi ap would not be detected by the controller software(controller software installed on device on same subnet/vlan).  It now doesn't work again and I am lost.  I think I might of did it right the first time by connecting my desktop directly into the AP and setting whatever settings worked then placing the AP back on the network.  But I am once again lost and have no wifi.  When I assign a different node to that same Vlan internet works fine.  It is isolated to this Unifi AP.  When I directly connect it to my desktop and ssh, it says connected, but "cannot resolve hostname"(no idea why it would say connected when it isn't plugged into a port on the switch connected to Pf)  When I plug the AP back into my switch, I ssh into it….and it simply says disconnected, which is to me counter intuitive and bizarre considering I am sshed into lol. More oddities is that the Unifi Enterprise AP has green leds indicating adoption into the network and is actually broadcasting an SSID, but it just says "secure, no internet" when I try to connect.  Help please

    EDIT: btw I did also try to ssh and set the inform url to the ip of the box running the controller software...issues.


  • LAYER 8 Global Moderator

    So by default the controller will find ap and vise versa when they are on the same layer 2

    What I would suggest is you factory reset the AP, and place it on the same layer 2 network the computer running your controller.

    Then when you find it, you can setup vlans for your different ssids.



  • Not a problem with the firewall, I do unifi setups all the time. Once you have the controller running, just take the ap's out of the box and plug them in. It's more complicated if you don't run the controller on the same subnet, but that's a UniFi issue, not a pfsense issue. If you want them on a different vlan, just leave the ports native on the vlan where your managent is, then tag the ssid to the correct vlan. (like johnpoz said).



  • Also, if your pfSense is virtualized, that the virtual switch is allowing vlan tags to pass (and/or configured for the correct vlan). I had this forgetful moment with ESXi for a good hour …  ::)



  • I tried same subnets, no vlan, vlan etc.  Must be buggy software or hardware I got? The fix was plugging the ap directly into my desktop and provisioning it from there.  It would only provision that way.  Then I plugged it into the vlan I configured previously and it was good to go…weird



  • I use unifi controller as a cloud controller for all my customers.  I generally provision them via SSH as I have better control and am able to confirm via cli that it has connected to the cloud controller.  Once it is in the controller I then can just plunk it into the customer environment.



  • I had the same problem before, but I solve it
    here's how i solve it.

    make sure you're on the same network with all of your unifi AP
    then run the unifi controller
    try to adopt all of the AP
    it it not work, hard reset all your AP and try to adopt them again

    if still not work, try unifi discover (you can download it from ubnt.com) to adopt it

    if some of your AP is isolated, use the wireless uplink from the nearest/strongest signal


Log in to reply