CaptivePortal Parando sozinho!



  • O Pfsense na versão 2.2.6-RELEASE (amd64) está parando o captive portal sozinho, alguém ai passando por isso?



  • Bom dia, estou tendo problema semelhante ao reportado.
    Percebi que quando ocorre é devido a um alto numero de usuários se autenticando, no meu caso aqui por volta de (2000) e a seguinte mensagem é exibida nos logs de sistema:

    Mar  8 21:47:07 pfsense2 php-fpm[14772]: /status_services.php: O comando '/usr/l
    ocal/sbin/lighttpd -f /var/etc/lighty-portal_wireless_CaptivePortal.conf
    ' retornou o c\xc3\xb3digo de sa\xc3\xadda '255', a sa\xc3\xadda foi '2016-03-08
    21:47:07: (network.c.416) can't bind to port: 0.0.0.0 8002 Address already in u
    se'

    O engraçado é que após isso é reiniciado o serviço do portal captive novamente, que volta a funcionar, mas é exibido na lista de serviços do pfsense como se tivesse parado.

    Algum bug da versão? alguma configuração?



  • @ma_rogerio:

    (network.c.416) can't bind to port: 0.0.0.0 8002 Address already in use'

    A mensagem indica que tem algum problema com a porta 8002 em uso.
    Uma solução poderia ser remover a zona e fazer novamente…



  • Ola Tomas, obrigado pelo feedback.

    Então, também fiz essa análise, que em tese esta correta pois quando o problema acontece tenho "N" usuários já conectados, ou seja, realmente a porta está em uso. O detalhe é o porque o captive para.
    Já tentei remover e criar novamente a Zona e houve o mesmo problema.

    Nessa nova versão foi alterado a porta para 8002 e percebi que é possível criar outras zonas para outras interfaces, caso tenha. Acha que isso poder ter alguma relação?
    Sabe me dizer que em alguma lugar é possível "limitar" a quantidade de conexões do captive portal?

    Estou montando uma outra máquina do zero já com a versao 2.2.6, pois essa que tenho em produção hoje foi atualizada. Devo colocá-la em operação ainda hoje para testes.


Log in to reply