Routing Netflix through WAN and else through VPN


  • I recently added a Private Internet Access VPN to my network using OpenVPN. I had not realized that Netflix was blocking VPNs. Is there anyway to have Netflix or other VPN aware blocks to be forwarded through the WAN?

    Thanks,
    Maxamus456


  • Just ran into the same issue.  I use PIA as well.  I've built a bypass for Hulu since PIA ip's are also on there block list.  You have to create an aliase with all the hostnames then create a firewall rule on the LAN tab to route all the traffic for those hostnames around the VPN.  I don't know if it will be possible with Netflix though because I read that they use a lot of different hostnames. Hulu uses 24 and the bypass I built for it works great.  I used a CND finder tool to try and look up Netflix hostnames but it only returned 3 which was sufficient for the bypass to work.


  • User knox203 has posted a link to a few lists of ip addresses for netflix that can be downloaded as zip file.  I've imported them as aliases and setup the firewall rules.  They seem to be working. I've also called Netflix and asked them if they could also post a comprehensive list on there support page.

    https://forum.pfsense.org/index.php?topic=107680.msg599757#msg599757


  • knight, I too ran into the same issue, but am having some trouble. Currently all traffic is sent over OpenVPN to PIA.

    I am very new to pfSense (had it a whole 2 days now) and it is not clear to me exactly how to implement this rule. Any help you can offer is greatly appreciated.

    In the rules i see the following:

    Action: Pass
    Disabled: unchecked
    Interface: LAN
    TCP/IP Version: IPv4
    Source:  Not sure what I should put here
    Destination: again, not sure what i should put here

    Advanced Features: many options here

    Thanks,

    -Edit
    Got if figured out and working!
    The key was to remove the two default rules pertaining to LAN traffic and adding one for the streaming services, and one for everything else. both rules required selected the appropriate gateway in advanced options.  Included are my rules for anyone else trying to figure this out.