Failing to configure optional internface



  • Hello,

    I did a fresh install of 1.3-alpha on my mini-ITX board with a pci Ralink wireless card in it.

    After the first boot I can configure most of the stuff, but I get an error message when trying to configure the wireless card. When I click 'OPT1' in the pulldown menu, I get some 'locate string' error in some php file.

    Since I don't have access to my box for the moment, I will post the exact error message this evening.

    Best regards,
    Jan



  • I get the same error..

    Fatal error: Cannot use string offset as an array in /usr/local/www/interfaces_wlan.inc on line 47 
    

    This is line 47.

    $pconfig['debug_mode'] = $optcfg['wireless']['wpa']['debug_mode'];
    

    Edit: Using 20080708-0315 with a Netgear WG311 (Atheros some thing)



  • Yep, that's the same error I'm getting.



  • I can confirm the same error using 20080708-1408.img on an Alix with a generic Atheros mini-pci card.



  • Same here. On a Acer 5620 using a Cisco ABG card

    Fatal error: Cannot use string offset as an array in /usr/local/www/interfaces_wlan.inc on line 47



  • Any ETA on a fix for this error?



  • Hi
    I faced the same error, but I find this
    http://cvstrac.pfsense.org/tktview?tn=1727,34
    by fellowing the instruction it's seem fix mine
    hope that will be helpful



  • fresh full install with pfSense-20080711-149.iso
    xl0 = WAN
    xl1 = LAN
    opt1 = WLAN = dwl-ag530

    I got the same error as others.

    When I commented out line 34 I was able to access the OPT1 configuration screen and configure the interface.

    This has allowed me to connect wirelessly but there are many things that don't seem right.

    1)On the console I get error messages "ath0: unable to reset hardware; hal status 12" and "ath0: unable to reset hardware; hal status 0"  I was not getting any error messages an hour earlier when I was running 1.2 stable

    2)When in bridge mode the console reports bridge0: invalid MTU for xl1, so I manually set both MTU to 1500.  This had no effect and the wireless MTU was still ~2200. Also the setting seemed to keep resetting to some default value.  I could not connect wirelessly in bridge mode(I don't know why).

    3)When I removed the bridge I no longer got the MTU error message.  I configured the interface and was able to connect wirelessly.  I closed the window and when I came back in to the screen the setting had changed.  For examples:  802.11g turbo to 802.11b(or 802.11g to 802.11b), AP mode to infrastructure, it didn't show SSID, my security setting unchecked/erased/or changed to default.

    4)This appears to be cosmetic because I even though the webgui shows 802.11b, I am connected at 54Mbps, I am broadcasting an SSID and to connect I need my WPA2 password.

    I don't know where to post all this I hope this was the right place if not feel free to move it or tell where to move it, Thx.  Let me know how I can help.

    Edit:  WOW!!!! You guys have been busy!  I am completely blown away with 1.3-alpha's appearance and features.



  • Fatal error: Cannot use string offset as an array in /usr/local/www/interfaces_wlan.inc on line 47
    This no longer happens on pfSense-20080714-1917.img
    There are still issues with wireless, but that should probably be another thread.


Log in to reply