Trouble with "No address record"



  • I am experiencing what seems to be a DNS resolving issue.  I cannot update packages.  I have tried several settings.  Below is what I think is relevant.  Any other suggestions on what I can try to resolve this?

    
    [2.2.2-RELEASE][root@mbr-corp-gw.xxxxxxxx.com]/root: cat /etc/resolv.conf
    search xxxxxxxx.com
    nameserver 8.8.4.4
    nameserver 8.8.8.8
    [2.2.2-RELEASE][root@mbr-corp-gw.xxxxxxxx.com]/root: nslookup
    > google.com
    Server:         8.8.4.4
    Address:        8.8.4.4#53
    
    Non-authoritative answer:
    Name:   google.com
    Address: 216.58.193.110
    > exit
    
    [2.2.2-RELEASE][root@mbr-corp-gw.xxxxxxxx.com]/root: pkg update
    Updating FreeBSD repository catalogue...
    pkg: http://pkg.FreeBSD.org/FreeBSD:10:amd64/latest/meta.txz: No address record
    repository FreeBSD has no meta file, using default settings
    pkg: http://pkg.FreeBSD.org/FreeBSD:10:amd64/latest/packagesite.txz: No address record
    Unable to update repository FreeBSD
    
    [2.2.2-RELEASE][root@mbr-corp-gw.xxxxxxxx.com]/root: ping www.google.com
    PING www.google.com (216.58.216.100): 56 data bytes
    64 bytes from 216.58.216.100: icmp_seq=0 ttl=52 time=993.095 ms
    64 bytes from 216.58.216.100: icmp_seq=1 ttl=52 time=769.334 ms
    64 bytes from 216.58.216.100: icmp_seq=2 ttl=52 time=667.440 ms
    64 bytes from 216.58.216.100: icmp_seq=3 ttl=52 time=649.040 ms
    64 bytes from 216.58.216.100: icmp_seq=4 ttl=52 time=677.038 ms
    ^C
    --- www.google.com ping statistics ---
    6 packets transmitted, 5 packets received, 16.7% packet loss
    round-trip min/avg/max/stddev = 649.040/751.189/993.095/127.902 ms
    
    

  • Rebel Alliance Developer Netgate

    Maybe it's trying IPv6? Try "pkg -4 update"



  • Thanks for the suggestion!  Tried explicitly IPv4, same results (x's to protect the innocent):

    
    [2.2.2-RELEASE][root@mbr-corp-gw.xxxxxxxx.com]/root: pkg -4 update
    Updating FreeBSD repository catalogue...
    pkg: http://pkg.FreeBSD.org/FreeBSD:10:amd64/latest/meta.txz: No address record
    repository FreeBSD has no meta file, using default settings
    pkg: http://pkg.FreeBSD.org/FreeBSD:10:amd64/latest/packagesite.txz: No address record
    Unable to update repository FreeBSD
    [2.2.2-RELEASE][root@mbr-corp-gw.xxxxxxxx.com]/root: nslookup
    > pkg.freebsd.org
    Server:         8.8.4.4
    Address:        8.8.4.4#53
    
    Non-authoritative answer:
    Name:   pkg.freebsd.org
    Address: 96.47.72.71
    > exit
    
    [2.2.2-RELEASE][root@mbr-corp-gw.xxxxxxxx.com]/root: ping pkg.freebsd.org
    PING pkg.freebsd.org (96.47.72.71): 56 data bytes
    64 bytes from 96.47.72.71: icmp_seq=0 ttl=52 time=666.302 ms
    64 bytes from 96.47.72.71: icmp_seq=1 ttl=52 time=631.953 ms
    64 bytes from 96.47.72.71: icmp_seq=2 ttl=52 time=623.120 ms
    ^C
    --- pkg.freebsd.org ping statistics ---
    3 packets transmitted, 3 packets received, 0.0% packet loss
    round-trip min/avg/max/stddev = 623.120/640.458/666.302/18.627 ms
    
    

    I have unchecked option: Allow DNS server list to be overridden by DHCP/PPP on WAN
    I have checked option: Do not use the DNS Forwarder as a DNS server for the firewall

    Interface setup:

    
    [2.2.2-RELEASE][root@mbr-corp-gw.xxxxxxxx.com]/root: ifconfig -a
    re0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            options=8209b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,wol_magic,linkstate>ether 00:30:18:c4:3f:60
            inet6 fe80::230:18ff:fec4:3f60%re0 prefixlen 64 scopeid 0x1
            inet 10.0.0.254 netmask 0xffffff00 broadcast 10.0.0.255
            nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect (1000baseT <full-duplex>)
            status: active
    re1: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            options=8209b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,wol_magic,linkstate>ether 00:30:18:xx:xx:xx
            inet6 xxxx::xxx:xxxx:xxxx:xxxx%re1 prefixlen 64 scopeid 0x2
            inet 10.149.81.82 netmask 0xfffffff8 broadcast 10.149.81.87
            inet6 2600:e008:6a:a2a0:230:18ff:fec4:3f61 prefixlen 64 autoconf
            inet6 fd0d:edc3:e12a:0:230:18ff:fec4:3f61 prefixlen 64 autoconf
            nd6 options=23 <performnud,accept_rtadv,auto_linklocal>media: Ethernet autoselect (1000baseT <full-duplex>)
            status: active
    re2: flags=8802 <broadcast,simplex,multicast>metric 0 mtu 1500
            options=8209b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,wol_magic,linkstate>ether 00:30:18:c4:3f:62
            nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect (none)
            status: no carrier
    re3: flags=8802 <broadcast,simplex,multicast>metric 0 mtu 1500
            options=8209b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,wol_magic,linkstate>ether 00:30:18:c4:3f:63
            nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect (none)
            status: no carrier
    pflog0: flags=100 <promisc>metric 0 mtu 33144
    pfsync0: flags=0<> metric 0 mtu 1500
            syncpeer: 224.0.0.240 maxupd: 128 defer: on
            syncok: 1
    lo0: flags=8049 <up,loopback,running,multicast>metric 0 mtu 16384
            options=600003 <rxcsum,txcsum,rxcsum_ipv6,txcsum_ipv6>inet 127.0.0.1 netmask 0xff000000
            inet6 ::1 prefixlen 128
            inet6 fe80::1%lo0 prefixlen 64 scopeid 0x7
            nd6 options=21 <performnud,auto_linklocal>enc0: flags=0<> metric 0 mtu 1536
            nd6 options=21 <performnud,auto_linklocal>re0_vlan30: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            options=3 <rxcsum,txcsum>ether 00:30:18:c4:3f:60
            inet6 fe80::230:18ff:fec4:3f60%re0_vlan30 prefixlen 64 scopeid 0x9
            inet 192.168.30.254 netmask 0xffffff00 broadcast 192.168.30.255
            nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect (1000baseT <full-duplex>)
            status: active
            vlan: 30 vlanpcp: 0 parent interface: re0</full-duplex></performnud,auto_linklocal></rxcsum,txcsum></up,broadcast,running,simplex,multicast></performnud,auto_linklocal></performnud,auto_linklocal></rxcsum,txcsum,rxcsum_ipv6,txcsum_ipv6></up,loopback,running,multicast></promisc></performnud,auto_linklocal></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,wol_magic,linkstate></broadcast,simplex,multicast></performnud,auto_linklocal></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,wol_magic,linkstate></broadcast,simplex,multicast></full-duplex></performnud,accept_rtadv,auto_linklocal></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,wol_magic,linkstate></up,broadcast,running,simplex,multicast></full-duplex></performnud,auto_linklocal></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,wol_magic,linkstate></up,broadcast,running,simplex,multicast> 
    

    Route information:

    
    [2.2.2-RELEASE][root@mbr-corp-gw.xxxxxxxx.com]/root: netstat -r
    Routing tables
    
    Internet:
    Destination        Gateway            Flags      Netif Expire
    default            10.149.81.81       UGS         re1
    google-public-dns- 10.149.81.81       UGHS        re1
    google-public-dns- 10.149.81.81       UGHS        re1
    10.0.0.0           link#1             U           re0
    mbr-corp-gw        link#1             UHS         lo0
    10.149.81.80/29    link#2             U           re1
    10.149.81.82       link#2             UHS         lo0
    localhost          link#7             UH          lo0
    192.168.30.0       link#9             U      re0_vlan
    192.168.30.254     link#9             UHS         lo0
    
    Internet6:
    Destination        Gateway            Flags      Netif Expire
    default            fe80::280:aeff:fe2 UGS         re1
    localhost          link#7             UH          lo0
    2600:e008:6a:a2a0: link#2             U           re1
    2600:e008:6a:a2a0: link#2             UHS         lo0
    fd0d:edc3:e12a::   link#2             U           re1
    fd0d:edc3:e12a:0:2 link#2             UHS         lo0
    fe80::%re0         link#1             U           re0
    fe80::230:18ff:fec link#1             UHS         lo0
    fe80::%re1         link#2             U           re1
    fe80::230:18ff:fec link#2             UHS         lo0
    fe80::%lo0         link#7             U           lo0
    fe80::1%lo0        link#7             UHS         lo0
    fe80::%re0_vlan30  link#9             U      re0_vlan
    fe80::230:18ff:fec link#9             UHS         lo0
    ff01::%re0         fe80::230:18ff:fec U           re0
    ff01::%re1         fe80::230:18ff:fec U           re1
    ff01::%lo0         localhost          U           lo0
    ff01::%re0_vlan30  fe80::230:18ff:fec U      re0_vlan
    ff02::%re0         fe80::230:18ff:fec U           re0
    ff02::%re1         fe80::230:18ff:fec U           re1
    ff02::%lo0         localhost          U           lo0
    ff02::%re0_vlan30  fe80::230:18ff:fec U      re0_vlan
    
    

    I think this might have something to do with the routes.  Its a 5 hour drive to site…

    Maybe I'll try an entry in the /etc/hosts file, and use log the DNS on the firewall for some hints...


Log in to reply